Sensorless Homing issue



  • Hi,

    I just installed a duet on my Anet A8 and I'm trying to configure sensorless homing/stall detection but I just run out of luck.

    My second printer is a Hypercube 500^3 which is working flawless without sensors so I went through the same steps and also copied some of the settings over to anet but it is doing nothing.

    Latest firmware RC4, all motors standard anet motors. I tried reducing the torque of the motors all the way down to 20% where I got a "motor phase error" and even tried sensitivity -60.

    Thanks!

    1_1542970743710_homeall.g 0_1542970743710_config.g



  • @ckostikas said in Sensorless Homing issue:

    I just run out of luck

    Although that may describe the actual problem, I fail to understand it. Can you rephrase it?



  • The actual problem is described on the title.

    The "run out of luck" means that I tried everything without positive effect aka the sensorless homing isn't working.


  • administrators

    What is the specification of the ASnet motors, and what VIN voltage are you using?



  • @dc42 said in Sensorless Homing issue:

    What is the specification of the ASnet motors, and what VIN voltage are you using?

    This is motors spec running them on 12v.

    The SL42STH40-1684A motor specs are:
    Step Angle: 1.8°
    Step Angle Accuracy: ±5% (full step, no load)
    Voltage: 2.8V
    Current per phase: 1.68A
    Resistance per phase: 1.65Ω
    Resistance accuracy: ±10%
    Inductance per phase: 3.2mH
    Inductance accuracy: ±20%
    Holding torque: 3.6 Kg·cm (0.4 N·m)
    Moment of inertia: 54 g/cm^2
    Weight: 0.28 kg
    Orientation torque: 150 g/cm
    Length: 40 mm
    Temperature rise: 80°C max (rated current, 2 phases on)
    Ambient temperature: -20°C ~ +50°C
    Insulation resistance: 100MΩ min, 500VDC
    Shaft radial play: 0.02 mm max (450g load)
    Shaft axial play: 0.08 mm max (450g load)
    Max. radial force: 28N (20mm from the flange)
    Max. axial force: 10N

    Found an other post of yours about changing the H parameter on M915 and I managed to get them staling ,when previously they where grinding without stopping, but I'm really far away from a proper homing.


  • administrators

    What homing speed are you using? If you have reduced the H parameter to get stall detection to work, then it might be better to set it back to its default value and instead increase the homing speed to be above that value.

    Low inductance motors like those are great for achieving high speeds, but not so good for stall detection because they produce less back emf.



  • Thanks for your input, I managed to get it working just by adding M400 in-between x and y homing so it would finish x first and then start y.

    It seems weird because everything is the same on both axis as per speed, sensitivity, H but it will not home simultaneously both of them.

    Anyway, thanks again! You can lock the thread.



  • @ckostikas said in Sensorless Homing issue:

    The actual problem is described on the title.

    The "run out of luck" means that I tried everything without positive effect aka the sensorless homing isn't working.

    Title states "Sensorless Homing issue", which says nothing.

    issue:

    • moves a bit and states that axis is homed
    • moves some random length and does the same
    • moves and crashes without motor stopping

    The reason I've asked for your actual problem because I've found out that the first one can easily be resolved by reducing acceleration during homing so the "start from zero" is not interpreted as "limit hit".


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.