Cancel print issue



  • Maybe I'm doing something wrong or not doing but I have a problem if I cancel a print on my delta. After canceling a print I wanted to get the effector out of the way so I clicked "Home All" in the DWC. The three carriages started heading up and crashed into the endstops and banged around for a few seconds. The only way I can clear this state is to power off and move the effector down and power up. I can then re-home and all is OK.

    This is repeatable. Every time I cancel a print and try to home it crashes into the stops.
    Is there something different I should be doing?

    This is with 2.02RC4 and latest DWC.



  • Can you post the contents of your pause.g and cancel.g files? Probably also your homing files.



  • Here are the files I have. There is no cancel.g file on the printer. Should there be one?

    pause.g
    ; Pause macro file
    M83 ; relative extruder moves
    G1 E-4 F2500 ; retract 4mm
    G91 ; relative moves
    G1 Z5 F5000 ; raise nozzle 2mm
    G90 ; absolute moves
    G1 X0 Y85 F5000 ; move head out of the way of the print

    resume.g
    ; Resume macro file
    G1 R1 Z2 F5000 ; move to 2mm above resume point
    G1 R1 ; lower nozzle to resume point
    M83 ; relative extruder moves
    G1 E4 F2500 ; undo the retraction

    homedelta.g
    ; Homing file for RepRapFirmware on Mini Kossel
    G91 ; use relative positioning
    ;******* Change F250 in the following line to F2500 when you are finished commissioning
    ;******* Change 320 in the following to a higher value if your Kossel has taller towers
    G1 S1 X320 Y320 Z320 F2500 ; move all carriages up 320mm, stopping at the endstops
    G1 S2 X-3 Y-3 Z-3 ; move all carriages down 3mm
    G1 S1 X6 Y6 Z6 F250 ; move carriages slowly up 6mm, stopping at the endstops
    G1 Z-10 F2000 ; down a few mm so that we can centre the head
    G90 ; back to absolute positioning
    G1 X0 Y0 F2500 ; centre the head and set a reasonable feed rate

    I also have a resurrect.g file
    ; File "AKLP_20mm_calibration_cube.gcode" resume print after print paused at 2018-11-26 16:44
    M140 P0 S70.0
    G10 P0 S205 R205
    T0 P0
    G92 X-2.041 Y-8.829 Z0.300
    M98 Presurrect-prologue.g
    M106 P0 S0.00
    M106 P2 S0.00
    M106 P3 S0.00
    M106 P4 S0.00
    M106 P5 S0.00
    M106 P6 S0.00
    M106 P7 S0.00
    M106 P8 S0.00
    M106 S0.00
    M116
    M290 S0.000
    G92 E14.26249
    M82
    M23 AKLP_20mm_calibration_cube.gcode
    M26 S6645 P0.000
    G0 F6000 Z2.300
    G0 F6000 X-2.041 Y-8.829
    G0 F6000 Z0.300
    G1 F3600.0 P0
    M24

    Note that there is no resurrect-prologue.g file on my printer.


  • administrators

    The only issue I see is these lines in resume.g:

    G1 R1 Z2 F5000 ; move to 2mm above resume point
    G1 R1 ; lower nozzle to resume point

    You should add parameters X0 Y0 to both those commands.

    Next time you pause or cancel a print, please send M574 without parameters, and check that the values it reports are still as you set them in config.g.

    The cancel.g file is optional, and is run when you cancel a print. The one on my delta contains G28. Note, if you have a cancel.g file the heaters won't automatically be turned off when you cancel a print, therefore you must do that in cancel.g if you want to.



  • @davea said in Cancel print issue:

    Note that there is no resurrect-prologue.g file on my printer.

    That file would need to be created by yourself if you wanted to be able to use resume after power failure.

    https://duet3d.dozuki.com/Wiki/Setting_up_to_resume_a_print_after_a_power_failure


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.