Motors will budge but not move



  • So I finally have firmware correctly installed on my DuetWifi and Paneldue and have everything connected to wifi so I can easily change firmware setting and try to get everything hooked up correctly. As usual, I've run into a few new problems. Firstly, I am using a 24v power supply and purchased these motors; https://www.amazon.com/gp/product/B00W9A2L3S/ref=oh_aui_detailpage_o06_s01?ie=UTF8&psc=1

    When I just plug a motor into the board and try to jog it using the machine control commands on either the touchscreen or the machine control panel over wifi, nothing happens. When I press to home the axis that it's on, the motor will sometimes budge just a little bit, maybe a 16th of a full rotation, but that's it. I'm just plugging in one motor at a time as I haven't wired the other ones up yet, and don't have an end-switch connected, does that matter? I'm currently driving the motors at 1.5a as they are rated for 2a. I've also noticed the Z axis won't budge at all, and the driver that runs it is INSANELY hot all the time in relation to the other drivers. Any thoughts?


  • administrators

    First of all, a reminder: never connect or disconnect motors with power applied. Doing so my damage the drivers.

    With no homing switches connected, using a config file set up for NC homing switches, it will appear that the homing switches are triggered. So there will be no movement when you try to home the printer. If your printer is a Cartesian or CoreXY then you should be able to jog the X and Y motors. The firmware may not allow Z movement before X and Y are homed depending on how your Z homing is configured.

    Regarding the hot Z driver, if it is hot even without a motor connected, then either the back of the Duet is shorting against something metallic behind it, or the Z driver is faulty.

    Have you checked which pairs of wires on your motors are the two phases, to make sure you have the wires connected correctly to the Duet?



  • Right, I don't plug in or unplug ANYTHING on the board while it's powered on, other then the USB cable. I'll try adding in the switches today and see if that makes a difference, as it hasn't wanted to jog on any of the axis. I'm sure the board isn't shorting against anything, so I guess my Z driver is faulty. I'm just going to be using one extruder, is it possible to fool the board to use the second extruder motor E1 as the Z axis? Or can I purchase another stepper driver and use that? Trying to avoid returning the board and waiting for two way shipping if I don't have to.

    For wiring, I've just been following this diagram and matching up the colors;


  • administrators

    Sorry to hear about your faulty Z driver. You can use the E1 driver to drive the Z motor if you put this in the movement section of config.g, before the M906 command:

    M584 X0 Y1 Z4 E3

    and connect your Z motor to the E1 motor output.

    Check that your motor phases are wired correctly like this. With the motor unplugged from the Duet, spin it by hand. There should be very little resistance. Number the pins of the motor connector that plugs into the Due 1-2-3-4 in order from one end and short pins 1 & 2 together. It should be much harder to spin. Similarly, if you short pins 3 and 4 together, it should be harder to spin.

    If it isn't harder to spin when you short 1-2 or 3-4, try shorting 1-3 or 1-4. If that makes it harder to spin, then the motor is wired incorrectly. You can remove the crimp pins over on the Molex connector by pressing down on the barb through the slot at the side and pulling gently on the wire. Then re-insert them in the correct positions.

    Alternatively, use a multimeter to check that you have continuity between 1-2 and between 3-4.



  • Ok, I'll give that a try, thanks.

    I just tried your suggested wire test, and weirdly the stepper motor I've been testing with doesn't become harder to spin no matter what I connect, so I'm assuming it's just a garbage motor. Tested a second one just now and wired it up, now it's working just fine. It's only moving about a full turn and a half when asked to move 100mm though, so I'm assuming I have to adjust something in the firmware as these are 0.9 degree motors and I think it's currently set up for 1.8 degree, as I believe they should be moving a lot more then that.



  • Something else I just noticed that's really weird is that it doesn't actually matter whether I plug the motor into X or Y on the Duetwifi, as jogging either the X or Y axis will move the motor regardless of which axis it's actually connected to. When the motor is connected to X and I jog Y, it moves much faster then if I had told it to move the same distance in X. ViseVersa for the Y axis. Thoughts?


  • administrators

    Sounds like you have a Cartesian printer but your config.g file is setup for a Delta or CoreXY printer. I suggest you go to https://configurator.reprapfirmware.org/ and generate a new set of system files that are correct for your printer. Then save the zip file it offers you and upload it through the Settings->General page of Duet Web Control.



  • It's actually a CoreXY printer, but I recompiled the firmware anyway making sure that it's set for a CoreXY, same problem. Is this how it's supposed to be for a CoreXY?


  • administrators

    With RepRapFirmware you don't recompile the firmware for CoreXY, you use the standard binary file and just set up the config.g file for CoreXY. If your config.g file isn't set up for CoreXY, that would explain the problem.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.