G30 S-1 Not Working



  • Trying to finalize my 1.17c setup and going through the steps in doing the mesh setup. When I give the G30 S-1 command, the bed moves away from the nozzle and then I get an error that the Z probe wasn't triggered. I am using a BL Touch sensor and it is working for homing and with G32. I'm guessing I have something wrong in the config, but not sure what. Here is my config.g file (minus the network stuff)

    [c]G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    ; Machine configuration
    M569 P0 S1 ; Drive 0 goes forwards (change to S0 to reverse it)
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M569 P4 S1 ; Drive 4 goes forwards

    M584 X0 Y1 Z2:4 E3:5:6 ; Add E1 as a second drive motor for the Z axis

    ; If you use an end stop switch for Z homing, change Z0 to Z1 in the following line,
    ; and see also M558 command later in this file
    M574 X1 Y1 Z0 S0 ; set end stop configuration (X and Y are low end stops active high)
    M667 S1 ; set CoreXY mode
    M906 X1000 Y1000 Z1100 E600 ; Set motor currents (ma)
    M201 X3000 Y3000 Z100 E4000 ; Accelerations (mm/s^2)
    M203 X3000 Y3000 Z400 E3600 ; Maximum speeds (mm/min)
    M566 X600 Y600 Z30 E20 ; Maximum jerk speeds mm/minute
    M208 X323 Y201 Z345 ; set axis maximum (adjust to suit your machine)
    M208 X-8 Y0 Z0 S1 ; set axis minimum (adjust to make X=0 and Y=0 the edges of the bed)

    M92 X100.86 Y100.86 Z389.8 ; set axis steps/mm - Direct

    ; Z probe
    M558 P4 X0 Y0 Z1 H5 F100 T2000 ; Switch for Z probe.
    ; Move 5mm between probes.
    ; Probe speed 100mm/min.
    ; Travel speed 2000mm/min.

    G31 X50 Y36 Z1.65 P5 ; Set the probe height and threshold (put your own values here)
    ; Probe is to the right and behind nozzle

    ; Configure pins for the BL Touch
    M307 H5 A-1 C-1 D-1 ; Using heater 5
    M280 P5 S90 I1 ; Make sure it starts retracted.

    ; Tool definition
    M563 P0 D0 H1 ; Define tool 0 - Using drive 0 (Extruder 0) and heater 1
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    M92 E417 ; Set extruder steps per mm - Titan Extruder

    ; Thermistors and heaters
    ; You can also use S and B parameters to define the parameters of the thermistors you are using
    M305 P0 T100000 R4700 B4540 ; Bed
    M305 P1 T100000 R4700 B4700 ; Hot End

    ; Bed M307 values generated from running M307 H0 D30 then M303 H0 P0.2 S90 and reading the results with M307 H0
    ;Heater 0 model: gain 312.8, time constant 651.2, dead time 11.8, max PWM 1.00, in use: yes, mode: PID
    M307 H0 A312.8 C651.2 D11.8 B0

    ; Hot End M307 values generated from running M303 H1 P0.3 S200 and reading the results with M307 H1
    ;Heater 1 model: gain 464.0, time constant 262.4, dead time 6.5, max PWM 1.00, in use: yes, mode: PID
    M307 H1 A464.0 C262.4 D6.5 B0
    M570 S180

    ;*** If you are using axis compensation, put the figures in the following command
    M556 S78 X0 Y0 Z0 ; Axis compensation here

    M106 P1 S0

    T0[/c]



  • Have you got your z motor/s turning the wrong way, so the z axis descends when it should raise?



  • Z axis is working fine. I can do the G32 bed.g leveling and printing with no problems. It is only the G30 command that is giving me problems.



  • Make sure your config.override file isn't messing with the P5 value for G31. I had that problem.

    Jeff



  • +1 for that I've had a few issues lately with config_override.g causing odd behaviours, I delete it periodically and copy the values back into config.g and re-calibrate.



  • I do not have an config.override.g that I am aware of but G30 S-1 is also causing me problems.
    Every time I use the paper test to set G92 Z0 and then raise the head 5mm
    G30 S-1 gives confusing information
    e.g. top right hand display shows Z= 2.92 but G-code console reports "Stopped at height of 1.876mm"
    Auto calibrate will stabilise at 0.015 but G29 bed levelling will then show a map with every point shown as negative!?
    homedelta.g looks fine as I have 250mm upright members on my "Big Delta" variant. (see below)
    Any none any ideas?

    ; Homing file for RepRapFirmware on Kossel
    G91 ;use relative positioning
    G1 S1 X250 Y250 Z250 F2500 ;move carriage up to ENDSTOP,
    G1 S2 X-3 Y-3 Z-3 ; move all carriages down 3mm
    G1 S1 X4 Y4 Z4 F250 ; move slowly up 4mm, stop at the endstops
    G1 Z-5 F2000 ; down a few mm so that we can centre the head
    G90 ; back to absolute positioning
    G1 X0 Y0 F2000 ; centre the head and set a reasonable feed rate


  • administrators

    If the trigger height of the BLTouch is greater than 5mm then you will need to raise the nozzle higher than 5mm before sending G30 S-1. Try 10mm or 20mm.

    The displayed trigger height and the Z height won't match if bed compensation is active, so it's best to measure the trigger height with bed compensation disabled.



  • thanks .
    Also just realised my homealldelta.g was rubbish, as my upright member is 750mm not 250mm 😞
    (must take it with more water in future)



  • Dropping Z to 10 before the G30 fixed it.



  • Well, while I did get it to work a couple times, when I went back and performed the steps here https://duet3d.com/wiki/Using_mesh_bed_compensation, the bed only moves away from the nozzle. I tried Z at 5, 10,15, and 20, all with the same results. 😞

    EDIT: I restarted the printer and homed all axis. I then moved Z to 10, deployed the probe, and tried G30 S-1 again. This time it worked. So one of those commands in the steps is causing the issue. Will see if I can figure out which one.

    EDIT 2: It seems the problem is with the M208 Z-3 command. This is setting the maximum Z travel to -3. I believe the command should be M208 Z-3 S1 to change the minimum Z travel.


  • administrators

    I'm glad you worked it out.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.