Slow WiFi upload



  • Hello,

    I'm also experiencing slow WiFi upload; already changed the SD card and that did not solve the problem. Upload speed drop after split second to <10 KiB/s... According to my router:

    Wireless LAN properties (2.4 GHz)
    Signal Strength-46 dBm
    max. data rate possible72 / 72 Mbit/s
    Current throughput52 / 54 Mbit/s

    M122 command returns:

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.01(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DGM-917NK-F23T0-6JTD8-3SJ6S-TZ8NH
    Used output buffers: 4 of 20 (18 max)
    === RTOS ===
    Static ram: 28476
    Dynamic ram: 96248 of which 16 recycled
    Exception stack ram used: 276
    Never used ram: 6056
    Tasks: NETWORK(ready,328) HEAT(blocked,1248) MAIN(running,3508)
    Owned mutexes:
    === Platform ===
    Last reset 00:01:45 ago, cause: software
    Last software reset at 2018-12-01 22:37, reason: User, spinning module GCodes, available RAM 6056 bytes (slot 0)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 9
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 5.3ms, max retries 0
    MCU temperature: min 36.4, current 36.6, max 36.8
    Supply voltage: min 12.2, current 12.3, max 12.3, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2018-12-01 22:38:59
    Slowest loop: 7.06ms; fastest: 0.07ms
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 167.25ms; fastest: 0.08ms
    Responder states: HTTP(3) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.21
      WiFi MAC address 84:f3:eb:83:38:2c
      WiFi Vcc 3.34, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 16440
      WiFi IP address 192.168.178.53
      WiFi signal strength -59dBm, reconnections 0, sleep mode modem
      Socket states: 2 0 0 0 0 0 0 0
      === Expansion ===

    Also tried to adjust orientation of the board, but that did not help.

    Board is HW 1.04v. Installed the board today, but with this speed it is actually not usable (and not worth the money..). I hope it can be fixed! Looking forward to hearing from you



  • Today I switched from one router to another (Asus to Netgear) and the difference was considerable. 100KiB/s for the asus 2 feet away from Duet to 400KiB/s for the netgear on the other side of the house. I don't know if there's any setting on the Asus that are different from netgear (or if it's brand or age). Switching cards did nothing for me either.



  • So, I did some more testing. Different router (separate wifi network) I was getting OK rate uploading a file using my phone. Connecting this router in LAN - Wifi bridge and uploading via my PC again did result in very slow rates. With my laptop (LAN or WiFi connection) I can achieve OK data rates with both my default router and the separate one.
    Conclusion: my PC is the issue (which is connected via LAN to my router)... I will debug some more to find the issue..



  • Got it! Using wireshark I saw a lot of traffic from my PC to my server --> It was running a backup.. Even though I also rebooted the PC today it did not stop the backup. Also I'm not sure exactly when the backup was started, it must have been running since yesterday morning..

    To conclude it had nothing to do with duet3d WiFi. Sorry for the inconvenience, now time for some more printing with this awesome board 🙂



  • @jasper said in Slow WiFi upload:

    To conclude it had nothing to do with duet3d WiFi. Sorry for the inconvenience, now time for some more printing with this awesome board 🙂

    Glad you got it sorted. Can you now mark this thread as "Solved".


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.