Z Probe - Omron PNP inductive sensor



  • Hi all

    How i connect my Omron PNP inductive sensor ( https://fi.farnell.com/omron-industrial-automation/e2a-m18ks08-wp-b1-2m/sensor-8mm-inductive-dc-pnp-m18/dp/1909135 ) right way to my Duet 2 Wifi.

    Everything else is wires ok, but not yet connect my Omron PNP signal wire to Duet, first think to ask here what is right way to do that?

    My Omron worked with ramps & with re-arm prosessor (3.3v). I have voltage divider allready there and my main voltage is 12volts.

    I measured with multimeter.

    • I get +9volts when sensor is triggered if my multimeter (positive) cabel is attached Omron sensor signal wire (with resistor divider) and multimeter (negative) wire is attached main supply gnd.
    • I get -3volts when sensor is triggered if my multimeter (positive) cabel is attached Omron sensor signal wire (with resistor divider) and multimeter (negative) wire is attached main supply +12vdc rail.

    Is this ok i connect (Omron sensor signal wire with resistor divider) directly to this Z Probe In - pin? 0_1544273267788_4ffaecb4-4d28-43e1-ba46-e859253de2ad-image.png





  • Moro 🙂

    Just readed that, but there is many warnings on old topic on forum NOT connect PNP sensor directly that board. (Board gets that full 12volts on that Z Probe in -pin.) Thanks you confirm with this 🙂

    Just not want broke my Duet because of that 🙂



  • Ok now my Z Probe works ok, if i check Machine control (Z probe state, when not triggered there is 0 and when triggered there is 1000). Also settings --> machine properties shows right way Z endstop hit status.

    Now i try but this kind of settings my probe:

    Config -file:
    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P5 H5 F300 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P500 X0 Y0 Z2 ; Set Z probe trigger value, offset and trigger height
    M557 X15:180 Y15:140 S20 ; Define mesh grid

    homez -file
    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Dec 08 2018 14:23:46 GMT+0200 (Itä-Euroopan normaaliaika)
    G91 ; relative positioning
    G1 Z5 F600 S2 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X15 Y25 F2000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    Now when i manually Home all axes. Y axis goes ok, X axis goes ok.

    When i hit Z axis home -button.

    • Z axis goes up little bit.
    • X and Y drives right places
    • And after that everything stop

    Duet3d web control gives this message:
    G28 Z
    Error: G0/G1: insufficient axes homed

    Hopefully someone can help how i get that normal z homing working. After that need to adjust sensor off set x and y places, but first need to get this normal Z home works.


  • administrators

    When you ask to home Z, do the X and Y axes already show as homed in Duet Web Control?



  • Yes, X and Y is homed ok, before i try home Z.

    Screenshot is taked just after click "Home Z" and printer is stopped after drive x 15 and y 25.

    0_1544287190184_ee08efa5-a1f8-459d-a259-a34a6ebf083d-image.png


  • administrators

    What type of printer is it? There is a known bug with homing SCARA printers in some firmware versions.

    If your printer isn't a SCARA, try sending the same commands that are in homez.g manually, one at a time.



  • Have Prusa i2 printer, totally worked ok with Ramps/Re-arm compination years. Normal cartesian printer.

    Sended that homez.file commands one at a time via g-code console.

    19.01.21 G30
    Error: G0/G1: insufficient axes homed
    19.01.15 G1 X15 Y25 F2000
    19.01.06 G90
    19.00.59 G1 Z5 F600 S2
    19.00.35 G91

    Everything else going ok, but that G30 gives that same error immediately when i send that to printer.

    edit: G28 gives same "Error: G0/G1: insufficient axes homed" error.

    edit2: One more screenshot if that tells something more:
    0_1544291089266_23d822a2-dfca-457a-8ad7-0b9882e30e4b-image.png

    Is this P5 right choice Z probe when i have this PNP induction digital sensor (with 10k resistor signal to ground). ( P5 (from RepRapFirmware 1.14) selects a switch by default (normally closed) for bed probing between the In and Gnd pins of the Z-probe connector (Duet 0.8.5 and Duet 2 WiFi).)

    Hopefully someone have tips. I dont get any ideas what i can try to get this working 😞


  • administrators

    Do you have any deployprobe.g or retractprobe.g files that you didn't create yourself? If so, delete them.



  • Just do my install with this tutorial, nothing more do yet.
    https://duet3d.dozuki.com/Guide/3.)+Configuration+(General+Cartesian)/10

    This files are generated that reprapconfigutator tool.

    retractprobe.g
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Dec 08 2018 14:23:46 GMT+0200 (Itä-Euroopan normaaliaika)
    M564 S0 ; don't apply limits
    G1 Z40 F10000 ; raise head
    G1 X-59 Y66 Z35 ; move over the post
    G1 Z7 F500 ; push probe down on post
    G1 Z35 F10000 ; raise head again
    G1 X0 Y0 ; move to somewhere sensible
    M564 S1 ; apply limits again

    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Dec 08 2018 14:23:46 GMT+0200 (Itä-Euroopan normaaliaika)
    M564 S0 ; don't apply limits
    G1 X25 Y93 Z40 F10000 ; put probe arm next to belt
    G1 X-5 F500 ; move probe arm across belt
    G1 X12 F1000 ; move probe back
    G1 X0 Y0 F10000 ; move to somewhere sensible
    M564 S1 ; apply limits again


    Is possible there is some more axles or something why that say "G0/G1: insufficient axes homed". Hard to find that problem because that not saying anything more than "insufficient axes homed", is there any place of web control or memory card where is going more exact log, where can find solution of this?

    Not understand what can be wrong. All axis moving ok, if i put g-code console: M564 S0 H0. Then every axis goes ok both directions. All limit switch give (hit endpoint) yes, when i push limit switches, same thing when put something metal near to z probe. All axis move out to limit switch if drive + numbers to millimeters, if but - millimeters axis goes nearer to limit switch.


  • administrators

    OK, I guess you checked the "Deploy/Retract probe" box. Please delete those files, and if you run the configurator again don't check that box.



  • Many thanks probing start to work and now all axis home ok. Many many thanks to you @dc42

    Tomorrow need to try setup probe offset. And try to know more better what is best choice to pick up bed leveling system. My old system do before everyprint 3point measuring on bed.

    If some link or recommeded tips i take all gladly 🙂

    Think to start with this links:
    https://duet3d.dozuki.com/Wiki/Setting_up_automatic_probing_of_the_print_bed
    https://duet3d.dozuki.com/Wiki/Using_mesh_bed_compensation

    Only thing dont know if these Y 40mm offset or is that -40mm, but maybe can try that tomorrow and be ready to click emernency button 🙂
    0_1544303297515_4ae96872-109a-4d57-9d80-57540ec93fb5-image.png


  • administrators

    The probe offset is measured from the head reference point (which is normally the nozzle) to the probe.



  • Thanks for info. Printer works like a charm now, first test parts printed without any problems and quality is very nice and steppers works very smoothie, i think because this awesome stepper drivers.


    One weird "problem" is on inside web control, when printing is going. First layer status seems calculate right.

    But after that whole print layer is sitting 2/10layers.

    Example pictures. Part is about 70% ready like progression bar tells, but Layer is 2/10 like see picture.
    0_1544369897492_4e7284e2-490d-48fb-8374-0c108c02647e-image.png

    Then wait little bit and progression bar goes ready(100% like screenshot (inside screenshot printer is still printing), still print continue about 2minutes and after that printer shutdown right way what i programmed on end g code.
    0_1544369908929_9ddc72ba-4fd5-4ee8-8be0-8dbfd56e20f2-image.png

    Parts printed ok, but some problem on that layer status or something.

    Here is gcode what is used to test and get that error. I use Prusa Slic3r.
    0_1544369755571_Part Studio 7 - Part 1petg.gcode

    Here my start gcode and stop gcode what i give on Slic3r start and stop gcode fields like my older printers.

    Start code:
    M80 ; virtalähde päälle
    T0 ; Tool valinta
    G90 ;absolute positioning
    M83 ; extruder relative mode
    M104 S[first_layer_temperature] ; set extruder temp
    M140 S[first_layer_bed_temperature] ; set bed temp
    ; Homing & leveling
    G28 ; Home all axis M80 ; virtalähde päälle
    G1 X95 Y95 F4000 ; Go to bed center before probing
    ;Wait for Temperature
    M109 S[first_layer_temperature] ; wait for extruder temp
    M190 S[first_layer_bed_temperature] ; wait for bed temp
    G30 ; Find the Z=0
    G29 S1 ; Load the height map from the last time I used G29 to probe the bed.
    ;Print intro line
    G1 Y193 F1000.0 ; go outside print area
    G92 E0.0 ; reset extruder

    Stop code
    M104 S0 ; turn off temperature
    M140 S0 ; Turn off bed
    G1 X100 ; 100 X axis
    G1 Y100 ; 100 Y axis
    M84 ; disable motors



  • I updated newer version that slic3r and that seems to solve that problem. Now just need to start learning everything what is possible with Duet. Big thanks fast help.

    p.s. Now just waiting when i get my PanelDue 7" and hope get that working 🙂



  • @dc42 said in Z Probe - Omron PNP inductive sensor:

    Do you have any deployprobe.g or retractprobe.g files that you didn't create yourself? If so, delete them.

    One question related to that. Printer works very good and new 7" PanelDue works perfect.

    Console gives every print error (web control and paneldue):
    Warning: Macro file deployprobe.g not found.
    Warning: Macro file rectractprobe.g not found.

    Print goes ok, but want that warning pop-ups disappier. Can i modify config or some file that kind not get that errors with that two files what i deleted.


  • administrators

    I think you have debugging enabled, otherwise you would not get those messages. If you have a M111 command in config.g then it should read: M111 S0

    You could also create new deployprobe.g and retractprobe.g files that contain just a comment line such as:

    ; Empty file
    

 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.