Robo3d AUTOLEVEL Not Working



  • Hi,
    Recently my robo r1 plus stopped doing the autolevel before a print, and I am not sure why. Perhaps I accidentaly deleted the proper scripts for the gcode in simplify3d? Here is a copy of my starting script
    G28 ; home all axes
    G29 ; probe the bed
    G1 Z5 F5000 ; lift nozzle
    M109 S[extruder0_temperature] ; set the extruder temp and wait
    G1 X15 Y0 ; move to begin wipe
    G1 X20 Z0 F4800 ; wipe

    Please let me know if you need anymore information to help troubleshoot this.
    Thanks and look forward to your repsonse


  • administrators

    When you run that script, does the G29 bed probing operation complete successfully? Do you get any error messages such as "Error: Z probe was not triggered during probing"?

    You can also run M122 after probing and check what the diagnostic reports says for "Bed compensation in use:".



  • I was getting the reading that the z probe was already triggered for g29 it doesnt not go through autolevel sequence. It used to say the z probe was triggered and continue to go through auto level and everything was working well. Not sure what got changed.


  • administrators

    So is it working now? If it isn't working, what error messages are reported?



  • @dc42 i am recieving the z probe error, and it will not go through the bed probing when i send g29 seems probe was already triggered? Not sure what to do



  • ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Oct 28 2018 16:32:40 GMT-0700 (Pacific Daylight Time)
    M561 ; clear any bed transform
    G28 ;
    ; Probe the bed at 4 points
    G30 P0 X15 Y15 H0 Z-99999
    G30 P1 X15 Y239 H0 Z-99999
    G30 P2 X215 Y239 H0 Z-99999
    G30 P3 X215 Y15 H0 Z-99999 S2
    G29 ;



  • ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Oct 30 2018 18:50:03 GMT+0800 (中国标准时间)
    G91 ; relative positioning
    G1 Z5 F4000 S2 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X25 Y25 F4000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F1000 ; lift Z relative to current position
    ;G90 ; absolute positioning


  • administrators

    I suggest you check that you have the correct M558 and G31 commands in config.g, and test the Z probe as described at https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe.



  • ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Oct 28 2018 16:32:40 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PRobo3d_R1+ ; Set machine name
    M551 Psafety13 ; Set password
    M552 S1 ; Enable network
    M587 S"elvis" P"honeynut" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X32 Y32 Z32 I0 ; Configure microstepping without interpolation
    M350 E16 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z1600 E816.32 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z300 E1500 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X15 Y15 Z0 S1 ; Set axis minima
    M208 X230 Y254 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 Z1 S0 ; Set active low endstops
    M574 X2 Y2 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ;
    M558 P4 I1 H5 F150 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:230 S50 ; Define mesh grid

    ; Heaters
    M307 H0 A134.3 C404.8 D0.4 B0
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S110 ; Set temperature limit for heater 0 to 110C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S300 ; Set temperature limit for heater 1 to 300C
    M501 ;
    ; Fans
    M107 P0 S0.6 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured



  • z endstop triggers when homing however fails to run bed probe sequence



  • when i try g30 it says not enough axes homes


  • administrators

    @sleepless said in Robo3d AUTOLEVEL Not Working:

    when i try g30 it says not enough axes homes

    In order to execute G30, the X and Y axes need to be flagged as having been homed. So either you hadn't homed X and Y between turning on the printer and sending G30, or you did something else (e.g. turned the motors off using M18 or M84) that caused them to be flagged as not homed.



  • ok i had to change g30 z0 to z-2now its doing autohoming, guess its time to calibrate the z height



  • 0_1548718633496_20190128_152941.jpg
    as you can see the auto level doesn't seem to be working very well, Do you think i need to run a mesh grid calibration?



  • @sleepless said in Robo3d AUTOLEVEL Not Working:

    Do you think i need to run a mesh grid calibration?

    It's a good way to see your bed topography even if you don't use the compensation feature.

    Did you end up getting a probe?



  • no i did not get the probe yet. mainly because i havent seen a design for the robo x carriage that houses the bltouch and i dont have time to design it at the moment


  • administrators

    Does your print bed have levelling screws? If so then I suggest you do true bed levelling adjustment before you run mesh probing. See https://duet3d.dozuki.com/Wiki/Using_the_manual_bed_levelling_assistant.



  • Not sure what I did but its working again : ) and dialed in



  • ![alt text](0_1548801743166_Screenshot (32).png image url)



  • Hi can you point me to some literature about clearing the compensation and running the calibration sequence in as many points as possible?


Log in to reply