Duete Wifi Connection Issues



  • Hello all,

    So I've had my Duet Wifi up and running for well over a year and it has been pretty well rock solid. Just today, I noticed that I couldn't connect to the Web Server via Chrome as I normally do so I started poking around.

    I noticed it was having a hard time connecting to my router as M552 S1 would often timeout or return "Failed while trying to connect to SSID". I tried sending M552 S0, then M588 S"*", M587 with my SSD info and it would connect (sometimes) but trying to ping it from my PC (connected to the router via Ethernet) returned oddities such as this:

    Pinging 192.168.50.50 with 32 bytes of data:
    Request timed out.
    Reply from 192.168.50.50: bytes=32 time=94ms TTL=255
    Reply from 192.168.50.50: bytes=32 time=4ms TTL=255
    Request timed out.

    I thought it might be an IP conflict (I changed my router a month ago but had no issues then) so I assigned the Duet a Static IP from my Router's config page (via the Duet's actual MAC, not a spoofed one). The Duet seems to think it can connect to it and reports an RSSI of between -45 and -49dB as well as my newly set IP address.

    However, I am still getting ping results like the one posted above and cannot functionally access the Web UI. It will occasionally begin loading the Web UI only to fail. More often than not, it simply will not connect to the router at all.

    I have just tried updating the WifiServer to 1.21 to no avail.

    Please help as I can't use my printer at all anymore...

    Thank you

    EDIT: Here is my M122 while connected as well as my latest ping result:

    m122
    === Diagnostics ===
    Used output buffers: 1 of 32 (1 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.19.2 running on Duet WiFi 1.0
    Board ID: 08DDM-9FAM2-LW4SD-6J9F2-3S86J-KLW7X
    Static ram used: 21176
    Dynamic ram used: 95888
    Recycled dynamic ram
    : 1720
    Stack ram used: 4048 current, 4888 maximum
    Never used ram: 7400
    Last reset 00:13:43 ago, cause: power up
    Last software reset reason: User, spinning module GCodes, available RAM 7180 bytes (slot 0)
    Software reset code 0x0003, HFSR 0x00000000, CFSR 0x00000000, ICSR 0x00400000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 29.7, current 34.8, max 35.1
    Supply voltage: min 24.1, current 24.2, max 24.5, under voltage events: 0, over voltage events: 0
    Driver 0: standstill
    Driver 1: standstill
    Driver 2: standstill
    Driver 3: standstill
    Driver 4: standstill
    Date/time: 1970-01-01 00:00:00
    Slowest main loop (seconds): 0.013967; fastest: 0.000000
    === Move ===
    MaxReps: 0, StepErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heater = 0, chamber heater = -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "m122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is connected to access point
    WiFi firmware version 1.21
    WiFi MAC address 60:01:94:34:38:94
    WiFi Vcc 3.32, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 16232
    WiFi IP address 192.168.50.50
    WiFi signal strength -38dBm
    Reconnections 0
    HTTP sessions: 0 of 8
    Socket states: 0 0 0 0 0 0 0 0
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)
    ok

    Pinging 192.168.50.50 with 32 bytes of data:
    Request timed out.
    Request timed out.
    Request timed out.
    Reply from 192.168.50.50: bytes=32 time=102ms TTL=255

    Ping statistics for 192.168.50.50:
    Packets: Sent = 4, Received = 1, Lost = 3 (75% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 102ms, Maximum = 102ms, Average = 102ms



  • After re-reading another thread I tried to make some changes in my config.g including changing my machine name as well as clearing my browser cache to no avail...

    Any help on this would be greatly appreciated.

    Thank you





  • I have gone through that Troubleshooter. The one thing I haven't done is put the Duet in AP mode so I'll try that and report back.



  • Just to provide an update here:

    It turns out the problem was wit h my router, an Asus RT AC86U. The 2.4GHz band is garbage. I am exchanging it tomorrow and will report back with the results.

    PS. The Duet worked perfectly in AP mode


  • administrators

    Thanks for the update! Someone else reported having problems with an ASUS router. OTOH my ASUS DSL-AC68U works well with my Duet WiFis.


Log in to reply