after new print z height get's a +2.0



  • So I have this really weird issue which i just can't get figured out.

    The problem: when I start a print, all goes well. The printer starts with fixing the tilt on one plane, does a small ABL, primes and prints along, so far so good. However: after this print has finished and I want to start a second print, this print starts with a z height of +2 (eg: in stead of 0.2, because the first layer is 0.2mm, the printer starts on 2.2, which results in some nice airprinting no need saying 😛 ).

    The samen happens when i cancel a print and start a new one. Restarting the duet completely solves it for the next print.

    I have digged through the configfiles but can't figure out where that +2 comes from.

    Configfiles for my Duet Wifi:
    [0_1544888213532_download.zip](Uploading 0%)

    My startup g-code is:

    ; Startup Gcode
    M83
    M140 S[first_layer_bed_temperature] ; set bed temperature
    M190 S[first_layer_bed_temperature] ; wait for temperature
    M104 S[first_layer_temperature]
    M561 ; Clear any bed transform
    G32 ; Do a single probe
    G29 ; Load heightmap (you can use G29 S1 instead)
    G1 Z20.0 F100 ; Move Z to 20
    G1 X10 Y10 F900 ; Move Head to front left
    M109 S[first_layer_temperature]
    G0 X5 Y10 F9000 ; Go to front
    G0 Z0.2 ; Drop to bed
    G92 E0 ; zero the extruded length
    G1 X40 E25 F100 ; Extrude 25mm of filament in a 4cm line
    G92 E0 ; zero the extruded length
    G1 E-1 F500 ; Retract a little
    G1 X80 F4000 ; Quickly wipe away from the filament line

    My End-gcode is:
    G10 P0 R-273.15 S-273.15 ; Turn off Tool0
    M140 S0 ; Turn off Bed
    M109 S0
    M106 S0 ; Object fan off
    G1 X0 Y0 ; Move Z to Z210
    G92 E0 ; Zero Extruder
    G1 E-2 F300 ; Retract 2mm
    G92 E0 ; Zero Extruder
    M84 ; All motors Off



  • and the fileupload is refusing a bit:

    wetransferlink for the configfiles


  • administrators

    Which firmware version are you using? Prior to firmware 2.01, homing Z while bed compensation was active sometimes caused a Z offset.



  • Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.02RC2(RTOS) (2018-09-07b2)
    WiFi Server Version: 1.21RC4(08b3)
    Web Interface Version: 1.22.3


  • administrators

    I don't recall an issue of that nature in 2.02RC2, but that's an old RC, so i suggest you upgrade to 2.02RC6. Also you should upgrade DuetWiFiServer to 1.21.



  • @dc42 as soon as the current print is finished, i'll give that a spin and keep you posted here about the results



  • @dc42 i think i finally found it 😄 When the ABL finishes, it puts the Z on +10 and starts moving to x20y20, when it reaches that point, the bed moves to z 0.2, but, the acceleration/speed of the Z-axis seemed to be too high, which made the motors skip steps. For the normal z-hop the acceleration is however no problem.

    Seems adjusting the accelerationsettings solves it.


  • administrators

    Thanks for the update!


Log in to reply