Issue with dual extruder



  • I have set up a BMG x2 on my machine and I have gotten it running but I am having an issue where the second extruder is running much slower than it should be. I have both extruders set to use the same steps/mm but the second one is running only about half the speed causing under extrusion.

    I have been searching for what might cause this but not finding anything.

    Here is what my config looks like for the drives, tools, and heaters section.
    Any insight would be greatly appreciated.
    Firmware Version: 2.02RC3
    WiFi Server Version: 1.21
    Web Interface Version: 1.22

    ;Drives*******************************************************************
    M569 P0 S0 ; Drive 0 (X) goes forwards (change to S0 to reverse it)
    M569 P1 S0 ; Drive 0 (Y) goes forwards (change to S0 to reverse it)
    M569 P2 S0 ; Drive 0 (Z) goes forwards (change to S0 to reverse it)
    M569 P3 S0 ; Drive 0 (E0) goes forwards (change to S0 to reverse it)
    M569 P4 S0 ; Drive 0 (E1) goes forwards (change to S0 to reverse it)
    M350 X16 Y16 Z16 E32:32 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z1600 E848.2:848.2 ; Set steps per mm
    M566 X1800 Y1800 Z100 E120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z2500 E2000:2000 ; Set maximum speeds (mm/min)
    M201 X800 Y800 Z200 E300:300 ; Set accelerations (mm/s^2)
    M906 X1400 Y1400 Z1500 E700:700 I30 ; Set motor currents (mA) and motor idle factor in percent
    M84 S30 ; Set idle timeout

    ;Tools*******************************************************************
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 ; Define tool 1
    G10 P1 X18 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ;Heaters*******************************************************************
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; Set temperature limit for heater 2 to 280C
    M307 H1 A396.9 C255.5 D5 B0
    M307 H2 A401.6 C241.4 D3.5



  • I'd remove the point from the M92 command, although not sure if that actually matters. I know it's very basic advice, but have you tried looking at the hardware? Your config settings are exactly identical for both extruders, so it would make sense to assume it's harware based. Maybe you accidentally mixed the stepper motors and one of them is 0.9 degrees and the other is 1.8.

    I'd try switching the stepper connectors on the board. If that changes which drive is overextruding - it's a hardware problem. If it doesn't - either a config bug or something's wrong with the board.



  • I feel like an idiot, in S3D I did not realize that you have to set the filament diameter for both extruders. I thought it was a global setting, so extruder 1 was using 1.75 and extruder 2 was using 3.00.


Log in to reply