Z height after homing



  • I am getting really frustrated with this and about ready to haul the printer off to the trash because of this. I cannot seem to get the Z axis to set to the correct height after homing. As a result, the nozzle is either too close or too far away from the bed. No matter what value I put in the G31 command, the nozzle position doesn't change after homing. With my Printrbot Simple Metal, there is the M212 command that can be used to adjust the initial height after homing so if you start a print and find the nozzle isn't low enough, or is too low, you can just adjust the value in M212 and print again. I hoping to find something similar in the Duet. After I start a print, if I find the nozzle is out of position, I stop the print, adjust the value, and start the print again. I'm not talking about babystepping during the first layer. I just want to be able to have the Duet agree with reality as the the position of the nozzle in relationship to the bed after being homed.


  • administrators

    Can you confirm that you are using the Z probe for Z homing? If so, what type of probe is it, and what xy coordinates do you set when Z homing? I recommend using the centre of the bed.

    How have you been adjusting the G31 Z parameter?



  • I am using a BLTouch, but had been using an inductive sensor before that and having the same problem. It is the only sensor on the Z axis. I do use the center of the bed for homing. I have been modifying the Z value of G31 but it doesn't seem to do anything. I can make a large change in the value, like 1mm, with no change in the actual height after homing. The Z axis on the PanelDue and web interface shows Z as 0.


  • administrators

    A change to the G31 Z parameter won't have any effect until you home Z again.

    Bear in mind that if you have a M501 command in config.g, the config-override.g file probably contains a G31 command too.



  • There is no config-override.g file and I haven't used the M501. I make the change to G31 in the config.g file and restart the printer. The next time I home, the distance between the bed and nozzle is still the same.

    I just set it to [c]G31 X50 Y36 Z10.56 P5[/c]. Bed/Nozzle distance still the same and Z says it is at 0.

    [c]; Z probe
    M558 P4 X0 Y0 Z1 H2 F25 T2000[/c]


  • administrators

    What do you have in your homez.g and homeall.g files? Perhaps you have them set up to use a Z microswitch instead of the Z probe. See https://duet3d.com/wiki/Configuring_RepRapFirmware_for_a_Cartesian_printer#Homing_files.



  • Okay. The G30 in the homeall.g file was the trick. Thanks.



  • I'm sorry for bringing this topic up again, but since it helped me out with the same exact problem already, I felt like I don't need to make a whole new post for it. So thanks for that already!

    At least for me, this "z-probe configuration as a microswitch instead of a z-probe" was generated by the RRF configuration tool, and as I pretty much just got my board and didn't have a clue about how everything works, I absolute didn't suspect this tool to be the culprit here.

    The thing is, when you use the configuration tool, you have a few options for how the Z-probe is going to work, just like you have different modes to set with M558. But I couldn't see the direct connection between the modes and the options presented there.

    Since I have a NPN inductive sensor that outputs either 1 or 0 and since I basically used it as a "microswitch" in Marlin, on the Z endstop pins, I felt like setting it up as a "Switch" as the tool calls it would be the best idea. Turns out, the generated homez.g and homeall.g are both setup as if it was an actual switch, using G1 to home instead of G30.

    I don't know how much influence you guys have on the RRF config tool, but I think as a new Duet user it is a very handy tool to use and it should be cleared up somehow what the "Switch" option does, or an actual "inductive/capacitive probe" option should be added as well to make it clear.

    Just my 2 cents as a Duet newbie. Aside from that, this board is absolutely fantastic!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.