Issue with the web interface not refreshing every 250ms



  • First off, I've posted this issue in the experimental FW thread with the same issue, but because of the time zone difference I'm putting out a new topic to hopefully more people see this.

    I have 2 Delta's, 1 Kossel Vslot from Ultibots, and 1 Rostock Max V2. Both are equipped with Duet Wifi's and until the other day both were on 1.16 Beta 10 with Web Interface version 1.12 and I had no issues with either.

    Now I tend to err on the side of caution and frequently live by "if it isn't broke, don't fix it" philosophy, but I went against my protocol and updated my Kossel first to the 1.17c+2 firmware and web interface 1.14a, and everything worked smooth and I had no issues.

    Now the Rostock Max was printing something so I couldn't do it at the same time but once it was finished I updated both the Firmware and the Web interface with the same exact files I uploaded to the Kossel Duet's Wifi and I've been having issues ever since. I was having weird retraction issues so I flashed it back to 1.17c and that fixed it, but now my error with the web interface is still showing it's ugly head, and frankly I have NO idea what is causing it.

    You know when you power down your printer, and you connect after a reboot you have the yellow ! saying A,B,C aren't homed etc. Well I home the Axis's and the message doesn't go away, it doesn't give me live up to date readings on the temp's even if I turn them on. I've reflashed it a few times and it still hasn't fixed anything so I don't know what to do or where to turn.

    I am using Chrome on a Windows 10 PC and it works completely fine with my Kossel interface but the max throws this error when I hit Shift, Control J.

    Uncaught TypeError: Cannot read property 'sort' of undefined
    at Object.success (dwc.js:2686)
    at i (dwc.js:2)
    at Object.fireWith [as resolveWith] (dwc.js:2)
    at A (dwc.js:4)
    at XMLHttpRequest. <anonymous>(dwc.js:4)

    I have no idea what that is, or how to fix it. I would try going to an older version for Chriss Hamm's github doesn't have older versions so I'm stuck on 1.14a.

    The only time it updates and work's correctly is if I'm printing something but once it's finished it doesn't work at all. Both printers are in the same room with the Wireless router, so signal isn't an issue as it never was before.

    If I had any hair on my head I'd be pulling it out, instead I've resorted to pulling out my beard hair, and I need to stop!! So someone, please help.

    Thanks</anonymous>


  • administrators

    I hope chrishamm will take a look at this soon. Meanwhile, any time the problem occurs, refresh the web page to get it updating again until the next exception.



  • I've been refreshing DC42 and it doesn't always work, if I start a print then it's not a problem and after the print is finished it will keep updating, but if i close the tab etc then open a new one it won't work. It's not a super big problem as long as it hoepfully gets fixed soon 😃



  • Still nothing on this? I'm still having the issue on my RoMax V2.


  • administrators

    I'm sorry I haven't been able to respond earlier, but now I have some time again to investigate your problem.

    Assuming you are using a Duet WiFi, can you confirm you are using my latest Duet WiFi Server version 1.03? There was an issue in prior versions that caused empty responses to be sent to the web interface and this issue looks exactly like it.

    Although I doubt an older version will resolve this problem, you can actually get older versions from my GitHub repository by looking through the list of commits. Here a link to the 1.12 DWC files, but be aware that it may not work properly with the latest firmware version: https://github.com/chrishamm/DuetWebControl/commit/edf9c9ba3f1148d67fbafeae0d6b20042705cb2a


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.