cura start gcode help



  • just finished with duet wifi installation on my corexy printer and tried to do a first print and few problem came up...
    with my ramps and same gcode i had bed heating first then bed levelling then noozle heating and then print.....
    now after the bed heat i had bed leveling and after that the printer started to print but the noozle temp was not ready yet..so by the time noozle was up to temp the first layer was gone so i had to cancel....
    my curaa start gcode ..M117 Heating... ; a simple comment on the LCD
    M190 S{material_bed_temperature_layer_0} ;heat bed to layer 0 before leveling (wait)
    M117 Leveling calculations... ;if you have BED LEVELING
    G28 ; home all axes
    G29 ; if you have BED LEVELING
    G1 X10 Y10 F6000 ; Move to start of bed
    M117 heating nozzle... ;a simple comment on the LCD
    M109 S{material_initial_print_temperature} heat nozzle to starting temp AND WAIT (avoids oozing)
    M117 Printing... ;a simple comment on the LCD
    M104 S{material_print_temperature_layer_0} ;start heating to proper temp of L0 WITHOUT waiting
    G0 Z0.3 ; drop to 0.3mm height
    G0 Y0 ; move to y=0
    G0 X50 F5000 ; move to x=50
    G92 E0 ; zero the extruded length
    G1 X100 E6 F300 ; start extruding (5cm line)
    G1 X150 E10 F300 ; end oft 5cm line
    G92 E0 ; zero the extruded length
    and my config
    M550 P"hypercube" ; Set machine name
    M552 S1 ; Enable network
    M587 S"kostasbmwx3" P"91171917" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.41 Y80.41 Z400.00 E905.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X600.00 Y600.00 Z650.00 E650.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X5 Y15 Z0 S1 ; Set axis minima
    M208 X200 Y190 Z150 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active high endstops

    ; Z-Probe
    M574 Z0 S1 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T2000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-8 Y-24 Z1.5 ; Set Z probe trigger value, offset and trigger height
    M557 X20:205 Y30:205 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B3950 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S80 ; Set temperature limit for heater 0 to 80C
    M305 P1 T100000 B4388 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S250 ; Set temperature limit for heater 1 to 250C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    thanks in advance


  • administrators

    In your Cura start script I suggest you remove the M117 command, also insert a T0 line before the M109 command. The rest looks OK to me, although I am not an expert on Cura.



  • ok i did that and the heater started heating nicely
    but i need about 1 minute before starts printing(thats how much time i need to get noozle to 200)
    is there a way to hold somehow the printing after bed heating + levelling so i have my noozle ready to desire temp???



  • You can add M116 to wait fo temps to be reached.

    https://duet3d.dozuki.com/Wiki/GCode#Section_M116_Wait


  • administrators

    @kostasbmw said in cura start gcode help:

    ok i did that and the heater started heating nicely
    but i need about 1 minute before starts printing(thats how much time i need to get noozle to 200)
    is there a way to hold somehow the printing after bed heating + levelling so i have my noozle ready to desire temp???

    Change the M109 command to use the first layer temperature, and remove the M104 command that is 2 lines later.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.