fans not working



  • ok i have a weird issue, i set up my fans to default settings fan0 as controlled, and fan1 to hotend(only have on extruder, on delta). like the following..

    M106 P2 H-1
    M106 P2 S0
    M106 P1 T45 B0.1 H1 ; enable thermostatic mode for fan 1
    M106 P0 H-1
    M106 P0 B0.1 S1 ; enable gcode controlled fan on 0

    but everytime i print (s3d as splicer) it never turns on the fan, even checked the print gcode file, it does send the code to tun it on after say layer 2 , but cooling fan never goes on. even sending a code to printer with paremeter "0" s1 it doesnt even start.

    and if i set up p2 as controlled fan, it starts up on printer initial start up and doesnt turn of unless i send sepreate code. nd also s3d only sends "m106 s1" to start cooling fan, and if i have it on P2 it never starts it ither, and i dont want to edit every gcode print i make to tell it to use p2 fan, unles theres a simpler way



  • Have you seen this? https://duet3d.dozuki.com/Wiki/Connecting_and_configuring_fans

    Are you able to control the part cooling fan0 from the slider in the DWC?



  • yup i used that link to connect and configure them, and nope, iv never gotten that slider to work, also doesnt even work with the terminal hotend fan.



  • could it b tht maybe the board being the problem


  • administrators

    To test a fan (fan 1 in this example):

    • Send "M106 P1 H-1 S0". The fan should be off after sending this.
    • Send "M106 P1 S1". This should turn the fan on.
    • Send "M106 P1 S0.5". This should run the fan at a slower speed.
    • To test fan 0 or fan 2, use P0 or P2 instead of P1 in the above commands.


  • @dc42 i know all that, i know i have my commands right, its still not doing what its supposed to, i there anything else it could b, P0 does not do what its supposed to, if it does work and if i use p2 in initial setup, the fan starts when printer starts up and dont stop unless i send the gcode to stop it, and then just the code "m106 s1" that the splicers send does would not work


  • administrators

    1. It's not clear to me from your posts whether or not fan 0 works when you test it manually. To test it, see my previous post, but use P0 instead of P1.

    2. M106 Snnn without a P parameter (as generated by most slicers) will default to using fan 0, unless you have used the F parameter in your M563 commands in config.g to select a different fan.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.