Prints are not in the center of the Bed



  • Hi

    i solve one problem and the next is comming šŸ˜‰

    i have the problem that my print are not in the center from my bed,what i can do to solve it ?

    X = 220
    Y = 220
    Z = 240

    config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 15 2018 20:53:32 GMT+0100 (MitteleuropƤische Normalzeit)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PAM8 ; Set machine name
    M552 S1 ; Enable network
    M587 S"WLAN-363335" P"luigello20101984" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X100 Y100 Z400 E112 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X24000 Y24000 Z480 E3000 ; Set maximum speeds (mm/min)
    M201 X2000 Y2000 Z100 E10000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E900 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X220 Y220 Z240 S0 ; Set axis maxima
    ;M208 X0 Y0 Z0 S1 ; Set axis minima
    ;M208 X220 Y220 Z240 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low endstops

    ; Z-Probe
    M558 P5 H5 F0 T6000 ; Set Z probe type to switch and the dive height + speeds
    M557 X5:215 Y20:195 S42:35 ; Define mesh grid

    ; BED
    M305 P0 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C

    ;E3D
    ;M305 P1 T100000 B4388 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    ;M143 H1 S320 ; Set temperature limit for heater 1 to 280C
    M143 H1 S320 ; Set the max temp of the hot-end in c-default is 280c
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; E3D thermistor
    M307 H1 A386.0 C107.3 D3.9 B0 ;Set E3D to use PID mode

    ; Fans
    M106 P0 S0 I0 F100 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0.75 I0 F500 H0 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Hotend" D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured
    ;M671 X3:2017:217 Y108:3:2013 P0.5
    M404 N1.75 D0.4
    M376 H10
    M207 S3.5 F1920 Z0.0

    ;Miscellanous
    T0

    homeall.g

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 15 2018 20:53:32 GMT+0100 (MitteleuropƤische Normalzeit)
    G91 ; relative positioning
    G1 Z5 F3000 S2 ; lift Z relative to current position
    G1 S1 X-220 Y-240 F3600 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F3000 ; go back a few mm
    G1 S1 X-220 Y-240 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G1 S1 Z-220 F900 ; move Z down stopping at the endstop
    G1 Z2 F3000
    G1 S1 Z-240 F180
    G90 ; absolute positioning
    ;G92 Z0 ; set Z to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    homex.g

    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 15 2018 20:53:32 GMT+0100 (MitteleuropƤische Normalzeit)
    G91 ; relative positioning
    G1 Z5 F3000 S2 ; lift Z relative to current position
    G1 S1 X-240 F3600 ; move quickly to X axis endstop and stop there (first pass)
    G1 X5 F3000 ; go back a few mm
    G1 S1 X-240 F360 ; move slowly to X axis endstop once more (second pass)
    G1 Z-2 F3000 S2 ; lower Z again
    G90 ; absolute positioning

    homey.g

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 15 2018 20:53:32 GMT+0100 (MitteleuropƤische Normalzeit)
    G91 ; relative positioning
    G1 Z5 F3000 S2 ; lift Z relative to current position
    G1 S1 Y-240 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F3000 ; go back a few mm
    G1 S1 Y-240 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 Z-2 F3000 S2 ; lower Z again
    G90 ; absolute positioning

    homez.g

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 15 2018 20:53:32 GMT+0100 (MitteleuropƤische Normalzeit)
    G92
    G1 S1 Z-240 F900
    G1 S2 F3000
    G1 S1 Z-240 F180
    G90

    thanks a lot





  • @lui2004 Make sure your slicer knows the bed size and where X0,Y0 is.



  • I just try all but is not in the Center.

    I will be back to my old config in first post

    Sorry for my Bad english

    Can you help me

    Thx



  • If your steps/mm are correct (prints have the expected size), your (0,0) point matches what you configured in slicer and your bed size (X & Y sizes) is correctly configured in slicer it is impossible for your prints to not be in the center of the bed.
    Post slicer setup and real pictures with an off-center print.



  • This are my settings in S3D - For Abs with E3D-V6 Bowden

    9_1545505414677_10.jpg 8_1545505414676_9.jpg 7_1545505414676_8.jpg 6_1545505414676_7.jpg 5_1545505414676_6.jpg 4_1545505414676_5.jpg 3_1545505414675_4.jpg 2_1545505414675_3.jpg 1_1545505414675_2.jpg 0_1545505414674_1.jpg

    picture from print will come in few minutes



  • @lui2004 I'm not really familiar with S3d, but I don't see anywhere to configure the bed in your screenshots. It's probably in the printer configuration rather than print settings.

    Perhaps this will help: https://drmrehorst.blogspot.com/2017/08/setting-up-3d-printers-origin.html



  • pictures off-center print

    0_1545506679692_20181222_201757.jpg



  • settings for bed in S3D

    0_1545506638876_11.jpg



  • Question, when your print head is in the homed position, is it actually off the edge of your bed? You may need to use a negative axis minima in your M208 command in config.g to account for the distance the nozzle is off from the edge of the print bed.



  • my position after home all

    0_1545507181411_20181222_203008.jpg



  • @lui2004 said in Prints are not in the center of the Bed:

    M208 X0 Y0 Z0 S1 ; Set axis minima

    So you may need to adjust your minima to account for that distance.

    If that's the X axis, you could use: M208 X-20 Y0 Z0 S1 ; Set axis minima

    That would shift the 0,0 position 20mm over to the right in that image and should place it on the bed, which should shift your bed center over as well.



  • i will try it

    thanks


Log in to reply