BLTouch not triggering



  • Hi there.
    So I got my Duet3D Wifi boar today and installed/wired everything up.
    So far everything works.
    However, when I want to home the Z axis, the pin deploys, Z axis goes down but when the pin then retracts it just keeps going and it doesn't stop (only when I power the machine off).

    Fix?

    Config file:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Fri Dec 28 2018 13:58:12 GMT+0100 (Midden-Europese standaardtijd)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"AM8" ; Set machine name
    M551 P"itsasecret: ; Set password
    M552 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X200.00 Y200.00 Z800.00 E420.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X220 Y220 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X0 Y0 S0 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F100 T2000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X31 Y-8 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:0 Y15:195 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M307 H1 A390.2 C216.6 D6.7 B0

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    deployprobe.g

    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Fri Dec 28 2018 13:58:13 GMT+0100 (Midden-Europese standaardtijd)
    M280 P3 S10 I1

    retractprobe.g

    ; retractprobe.g
    ; called to retract a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Fri Dec 28 2018 13:58:13 GMT+0100 (Midden-Europese standaardtijd)
    M280 P3 S90 I1



  • After changing the following line:

    M558 P9 H5 F100 T2000 ; Set Z probe type to bltouch and the dive height + speeds

    To

    M558 P4 H5 F100 T2000 ; Set Z probe type to bltouch and the dive height + speeds

    And then try to home Z I'm getting the following error:
    G28 Z

    Error: Z probe already triggered at start of probing move
    Error: Homing failed

    However now that I changed the P value to 4 I'm getting a Z-Probe readout of 1000 when the pin is in and out on WBC wich I didn't have before (Reading of 1000)



  • @r3play Have you tried inverting the probe reading. Add a I1 to the M558 line.



  • @stephen6309 said in BLTouch not triggering:

    @r3play Have you tried inverting the probe reading. Add a I1 to the M558 line.

    I've added a I1 to the M558 command line, but it stays the same.
    Pin goes out, lowers Z, but when I push the pin in (manually) it just deploys it back while Z keeps moving down.



  • Update

    Current settings:

    Config file

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Fri Dec 28 2018 13:58:12 GMT+0100 (Midden-Europese standaardtijd)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"AM8" ; Set machine name
    M551 P"itsasecret: ; Set password
    M552 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X200.00 Y200.00 Z800.00 E420.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X220 Y220 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X0 Y0 S0 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F100 T2000 I1 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X31 Y-8 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X15:0 Y15:195 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M307 H1 A390.2 C216.6 D6.7 B0

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    Probe is ALWAYS reading 1000.
    So it's always assuming that the "endstop" is hit, wether the pin is deployed or retracted.
    When I remove the I1 from the M558 command it just shows 0 deployed or retracted.

    Wiring:
    0_1546019308140_20181228_184657.jpg

    Basically using this wiring:
    alt text

    I also have checked the white wire and it makes a connection.

    When sending M401 manually the pin deploys
    When sending M402 manually the pin retracts

    0_1546020439654_Screenshot_50.jpg



  • TOPIC CAN BE CLOSED.

    After 6 hours of struggling and trying I eventually found out I switched the black and white wires... facepalm

    Glad I found the problem!
    BLTouch works perfectly now.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.