Testing Duex5... cant get fans to work



  • I have a new Duet ethernet and Duex 5 I am setting up. I have power (24.15 volts) going to the Duet and Duex5 and checked both with a multi-meter. Using M115 is get "FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.02(RTOS) ELECTRONICS: Duet Ethernet 1.02 or later + DueX5 FIRMWARE_DATE: 2018-12-24b1" so it should be connected correctly. I am trying to test a 12 volt fan so on the Duex5 I have the V_FAN_JUMPER in the middle for 12 volts. I have in my config.g for fans the following:

    M106 P0 S1 I0 F500 H-1 ;C"Tool1" ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 C"Tool2" ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 C"Tool3" ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P3 S1 I0 F500 H-1 C"Tool4" ; Set fan 3 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P4 S1 I0 F500 H-1 C"Tool5" ; Set fan 4 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P5 S1 I0 F500 H-1 C"Tool6" ; Set fan 5 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P6 S1 I0 F500 H-1 C"Tool7" ; Set fan 6 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P7 S1 I0 F500 H-1 C"Tool8" ; Set fan 7 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P8 S1 I0 F500 H-1 C"Tool9" ; Set fan 8 value, PWM signal inversion and frequency. Thermostatic control is turned off

    When I connect a 12 volt fan to the Duex5 fan 3 and adjust it in DWC i get no movement. I also checked with a volt meter and see no voltage. Any tips??



  • Think I have i may have it figured out but cant test it as I dont have a jumper... but it looks like I have to set the fan voltage jumper to 12 volts as well as the 12v EN jumper. Can anyone confirm this? Thanks.


  • administrators

    @nikker said in Testing Duex5... cant get fans to work:

    Think I have i may have it figured out but cant test it as I dont have a jumper... but it looks like I have to set the fan voltage jumper to 12 volts as well as the 12v EN jumper. Can anyone confirm this? Thanks.

    If your VIN is 24V, that is correct. If VIN is 12V, set the fan voltage selector jumper to VIN instead of to 12V.


Log in to reply