Cannot PID tune my heater at all??



  • Every time I try to run M303 and autotune the heater, I get the message "No heater has been tuned yet" And it won't let me do anyting. The reason I'm trying to tune the heater is because I keep getting "Heater Fault, heater heating to slowly 0.7C/sec" I can't run any prints, it just errors out. I can't test my new Titan Extruder because it won't get hot enough to extrude PLA...I'm running a 24V 500 watt 20 amp Meanwell PSU and it seems to be working fine...it just seems like the power to the heater unit is fluctuating. I've replaced the heater and thermistor twice (once with older working ones and then with brand new E3D ones) and they are the correct voltage and wattage because I tested them on my LulzBot and they both worked fine. I'm stuck...what can I do to fix this heater issue??

    Also - I had one other question...where do you set up the nozzle size? Whether its 0.4mm or 1.0mm? I cannot find it in the Duet2 controls anywhere??



  • To tune your heater you have to use something like: M303 H1 S220, see https://duet3d.dozuki.com/Wiki/Gcode#Section_M303_Run_heater_tuning for more details.

    The nozzle size is set in your slicer program. The Duet does not need to know anything about it.



  • I got the heater tuned just fine...used the guide that I found on the duet site. Now I have a much worse problem - every time I start a print, the Titan Aero that I'm using clogs in the throat/pipe or it bunches up in the hobbed gear. I tried several different temps and they all do the same thing. I followed the setup instructions on E3D's wiki page and it seemed like it all fit into place correctly, set the steps/mm (837) and then attached it to the printer (that's when I started having issues with the heater cuz it was brand new I guess) I finally got the heater working correctly (I thought) and now I can't even get one minute into any print job without it clogging up completely to the point that I have to disassemble it ...WTF am I doing wrong?? I dumped the TronXY motherboard cuz it kept having one issue after another, now the Duet2 is doing the same thing!! I am really about to give up on 3D printing all together...thousands of dollars invested and not one printer works the way its supposed to...



  • How much retraction are you using?

    What temp and material are you using?

    How fast are you trying to print?

    What happens if you heat up the hotend to temp and try to manually extrude filament at a slow rate?


  • administrators

    What extruder motor and microstepping settings are you using? Have you checked that the extruder extrudes the correct amount? 837 steps/mm is about right for a 0.9deg motor using x16 microstepping. If your motor is 1.8deg then you need to halve the steps/mm.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.