Trying to understand M584 driver mapping



  • I have recently started using a Duet board and have built a 400 X 400 machine that uses two lead screws for the Z axis. I have connected both at the Z driver pins.

    When the weight of the bed is increased the Z motors struggle to lift the load. I planed to use the free E1 driver for one Z motor and the Z driver for the other motor.

    I tried adding the the following code.

    M584 X0 Y1 Z2:4 E3 ;

    I used it before M208 and M574.

    The Z axis now just vibrates violently . I have made sure not to flip the motor pins and have inserted them in the same orientation as before to avoid the motors rotating in opposite direction.

    Do I need to do anything else ??

    Also wanted to know if there will be a significant increase in the motors ability to lift load if I use independent drivers. I have increased driver current from 800mA to 1200mA and this seems to be helpful, but I do not want to push it from 1200mA.


  • administrators

    The two Z motor connectors on the Duet are wired in series. Unless you use low current/high resistance motors, both motors will get the current you set. Using separate drivers won't increase the torque, but ti will increase the Z movement speed you can get before the torque starts to reduce.

    Make sure that your M584 command is earlier in config.g than your M906 and M350 commands; and put 2 jumpers on the unused Zb motor output connector.



  • @dc42
    Im having problems to understand this. As right now im using only one port on the board for dual z drivers. But do i yet Have to use M854 in config file? As for endstop i use a switch and no probing. But the bed not seem to want to use as after homing as 0 -min. Each time i start new print i have to home all and then start new print.. and use baby steps to get the correct height.



  • @maiki76

    If you are using a separate driver on the board then you need to use M584 and use jumpers on the unused motor connection pins

    The Z axis driver has two motor ports ( You can connect two motors to the same driver), in case you are doing this then you do not need M584 command


  • administrators

    @maiki76 said in Trying to understand M584 driver mapping:

    As for endstop i use a switch and no probing. But the bed not seem to want to use as after homing as 0 -min. Each time i start new print i have to home all and then start new print.. and use baby steps to get the correct height.

    I suggest you look at https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_Z.



  • @hussainsail2002 Yes i do know this and i used both of ports at start. But after i started using setup as XY then this started... So the one port B is disabled..



  • @dc42 Thank you.. I check later 🙂


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.