E3d V6 and KEENOVO Silicone Heater



  • Hey Guys trying to tune my E3d V6 and KEENOVO Silicone Heater 400x400mm 1000W 110v. The hotend and Bed heat up.

    ; Heaters
    ;Bed
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    ;E3dv6
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; Set temperature limit for heater 2 to 280C


    M307 H0
    Heater 0 model: gain 204.4, time constant 836.7, dead time 1.5, max PWM 1.00, calibration voltage 24.3, mode PID, inverted no, frequency default
    Computed PID parameters for setpoint change: P482.3, I13.547, D511.5
    Computed PID parameters for load change: P

    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 229C.
    Auto tune heater 0 completed in 1316 sec
    Use M307 H0 to see the result, or M500 to save the result in config-override.g

    Auto tune phase 3, peak temperature was 120.8
    Auto tune phase 2, heater off
    Auto tune phase 1, heater on
    M303 H0 S120


    M307 H1
    Heater 1 model: gain 800.1, time constant 205.0, dead time 5.2, max PWM 1.00, calibration voltage 24.3, mode PID, inverted no, frequency default
    Computed PID parameters for setpoint change: P8.8, I0.268, D32.0
    Computed PID parameters for load change: P8.8,
    PMM500
    Warning: No M501 command was executed in config.g
    PMWarning: Heater 1 appears to be over-powered. If left on at full power, its temperature is predicted to reach 825C.
    Auto tune heater 1 completed in 272 sec
    Use M307 H1 to see the result, or M500 to save the result in config-override.g
    PMAuto tune phase 3, peak temperature was 252.8
    PMAuto tune phase 2, heater off
    PMAuto tune phase 1, heater on
    PMM303 H1 S240
    Auto tuning heater 1 using target temperature 240.0°C and PWM 1.00 - do not leave printer unattended

    M307 H2
    Heater 2 model: gain 731.8, time constant 198.3, dead time 4.2, max PWM 1.00, calibration voltage 24.3, mode PID, inverted no, frequency default
    Computed PID parameters for setpoint change: P11.4, I0.393, D33.9
    Computed PID parameters for load change: P11.
    PMM500
    Warning: No M501 command was executed in config.g
    PMWarning: Heater 2 appears to be over-powered. If left on at full power, its temperature is predicted to reach 756C.
    Auto tune heater 2 completed in 271 sec
    Use M307 H2 to see the result, or M500 to save the result in config-override.g
    PMAuto tune phase 3, peak temperature was 249.7
    PMAuto tune phase 2, heater off
    PMAuto tune phase 1, heater on
    PMM303 H2 S240
    Auto tuning heater 2 using target temperature 240.0°C and PWM 1.00 - do not leave printer unattended



  • What is the issue? It looks like it worked.

    If you used M500 to save the results to config-override.g you'll need to add M501 to the end of your config.g to load them at startup.

    Alternatively, you can copy and paste the lines from config-override for H0 and H1 into config.g to make them permanent.



  • ; config-override.g file generated in response to M500 at 2019-01-02 15:07
    ; This is a system-generated file - do not edit
    ; Heater model parameters
    M307 H0 A204.4 C836.7 D1.5 S1.00 V24.3 B0
    M307 H1 A800.1 C205.0 D5.2 S1.00 V24.3 B0
    M307 H2 A731.8 C198.3 D4.2 S1.00 V24.3 B0
    M307 H3 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H7 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    G10 L2 P1 X0.00 Y0.00 Z0.00 U0.00
    G10 L2 P2 X0.00 Y0.00 Z0.00 U0.00
    G10 L2 P3 X0.00 Y0.00 Z0.00 U0.00
    G10 L2 P4 X0.00 Y0.00 Z0.00 U0.00
    G10 L2 P5 X0.00 Y0.00 Z0.00 U0.00
    G10 L2 P6 X0.00 Y0.00 Z0.00 U0.00
    G10 L2 P7 X0.00 Y0.00 Z0.00 U0.00
    G10 L2 P8 X0.00 Y0.00 Z0.00 U0.00
    G10 L2 P9 0.00 Y0.00 Z0.00 U0.00



  • @karim said in E3d V6 and KEENOVO Silicone Heater:

    M307 H0 A204.4 C836.7 D1.5 S1.00 V24.3 B0
    M307 H1 A800.1 C205.0 D5.2 S1.00 V24.3 B0
    M307 H2 A731.8 C198.3 D4.2 S1.00 V24.3 B0

    Copy and paste those into config.g for your 3 heaters. Maybe add a comment about what temp you tuned to.



  • This is what it should look like.
    ; Heaters
    ;Bed
    M143 H0 S120 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M307 H0 A204.4 C836.7 D1.5 S1.00 V24.3 B0 ; Set temperature limit for heater 0 to 120C

    ;E3dv6
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M307 H1 A800.1 C205.0 D5.2 S1.00 V24.3 B0
    M143 H2 ; Set temperature limit for heater 2 to 280C
    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 2
    M307 H2 A731.8 C198.3 D4.2 S1.00 V24.3 B0



  • @karim said in E3d V6 and KEENOVO Silicone Heater:

    M143 H2 ; Set temperature limit for heater 2 to 280C

    You've missed the temp limit for heater 2.

    Otherwise I think that looks ok.



  • @karim said in E3d V6 and KEENOVO Silicone Heater:

    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1

    Yea it ok now, I am testing it.

    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1

    This one had to fix too, change from P2 to P1.



  • Thank you, Everything seem ok.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.