Wifi always idle reported by terminal



  • On my Duet Wifi, I was attempting to reconfigure my wifi settings using the terminal, and now it never turns on blue anymore (except a little flash when I power up) When I try to run 552 S0 or S1, my terminal comes back with ""WiFi module is idle" I have also tried running my original scripts for setting and forgetting the network (exactly same as I ran to initially setup the duet) and again I get "Idle" back from the terminal.



  • It looks as though the wifi is not turning on at all. What are possible causes for no blue indicator when the Duet Wifi is fully powered up? Can that happen just because of a configuration problem?


  • administrators

    M552 S0 puts the WiFi module in the Idle state, so the "WiFi module is idle" message is expected in that case.

    M552 S1 should scan for known networks and try to connect to the strongest one. If it fails then it should produce an error message before it reports "WiFi module is idle".

    You could try re-installing the DuetWiFiFirmware file. In another thread I announced the availability of version 1.22beta.



  • @henrydara

    Just to make sure all of the basics are occurring as expected:

    Does M587 report the expected network?

    Did you delete existing networks with M588 S"*", then re-enter your expected network using M587 S“mynetwork” P”mynetworkpassword” (making sure that the case of each is correct)? Note that attempts to overwrite the network setting with M587 doesn't seem to work unless you delete the old one first - but it sounds like you did.

    When you enter M552 S1, the blue led should flash for a few seconds as it tries to connect. Then you should get a message back either saying that it is connected successfully with the IP address it obtained from DHCP reported, or you should get back a message saying that it failed to connect. Are you getting either message?



  • @dc42 I got it, thanks for the help. Im my own worst enemy sometimes. Thankfully you've been there to catch me.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.