Dual Z motors out of sync on regular move



  • my printer build box is 400x300x530, I have two Z motors they are on separate drives with separate endstops for automatic bed leveling, all movement and homing works fine.

    My problem is when i move the z axis the stepper motors has a different speed, my build box high is 500mm when i move from 0 to 500mm i god a difference from 6mm at the end.

    The strange thing is i have also two y motors the work with the same config perfectly.

    Any ideas how can i solve this?

    This is my config.g:

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PMonster ; Set machine name
    M552 P192.168.88.100 S1 ; Enable network and set IP address
    M553 P255.255.255.0 ; Set netmask
    M554 P192.168.88.1 ; Set gateway
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes forwards
    M569 P5 S1 ; Drive 5 goes backwards
    M569 P6 S0 ; Drive 5 goes backwards
    M584 X0 Y1:3 Z2:4 U3 V4 E5:6
    M350 X16 Y16:16 Z16:16 U16 V16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X396.82 Y396.82 Z396.82:396.82 U396.82 V396.82 E400:400 ; Set steps per mm
    M566 X900 Y900:900 Z200:200 U900 V200 E120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X4800 Y4800:4800 Z1500:1500 U4800 V1500 E3000:3000 ; Set maximum speeds (mm/min)
    M201 X250 Y250:250 Z250:250 U250 V250 E250:250 ; Set accelerations (mm/s^2)
    M906 X2000 Y2000:2000 Z2000:2000 U2000 V2000 E800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 U0 V0 S1 ; Set axis minima
    M208 X289 Y220 Z530 U220 V530 S0 ; Set axis maxima

    ; Endstops
    M574 X2 Y1 Z2 U1 V2 S0 ; Set active low endstops

    ; Z-Probe
    M307 H3 A-1 C-1 D-1
    M558 P9 H5 F100 T2000
    G31 X45.25 Y5 Z2.04 P25
    M557 X15:230 Y15:230 S50 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S300 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S300 ; Set temperature limit for heater 2 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1:2 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1:2 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X10 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 ; Define tool 1
    G10 P1 X-10 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured


  • administrators

    I'll assume that you have a bed that moves in the Z direction. Do the motors move the same amount when moving the bed down but different amounts when moving up? If so then you probably need to reduce Z and U acceleration in M201.

    You should use the M584 P3 parameter to hide the U and V axes except when you are homing them.


Log in to reply