RRF Tool Not creating accurate config.g?? WassuP?

  • Greeting and Salutations,

    Tried the RRF Online configurator and tried to set a static IP addy on my Duet Ethernet (See attached Pic). After Upload the Board came back up with a different addy than what I assigned. Looked at my config.g and could not find a M552 with any ip addy? Weird Huh? I just edited my config file but now I'm starting to wonder what else I asked for that I'm not getting? The struggle is real yo!! 0_1546914426993_Sprite 6.jpg

  • administrators

    I'm sorry, I can't reproduce that. This is the start of the config.g file that it generated, using those settings:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Jan 08 2019 15:13:28 GMT+0000 (Greenwich Mean Time)
    ; General preferences
    G90                                         ; Send absolute coordinates...
    M83                                         ; ...but relative extruder moves
    M665 R105.6 L215 B85 H250                   ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0                               ; Put your endstop adjustments here, or let auto calibration find them
    ; Network
    M550 P"My Printer"                          ; Set machine name
    M552 P192.168.0.230 S1                      ; Enable network and set IP address
    M553 P255.255.255.0                         ; Set netmask
    M554 P192.168.0.1                           ; Set gateway
    M586 P0 S1                                  ; Enable HTTP
    M586 P1 S0                                  ; Disable FTP
    M586 P2 S0                                  ; Disable Telnet

  • Thank you for looking at this. I've tried multiple times to create new firmware files but I still do not get correct IP address settings. I can't imagine why this is the case? Maybe I need to clear the cache on my browser??? Weirdness.

  • administrators

    Please clear your browser cache and try again. Assuming it still doesn't generate the correct file, post the config.json and the config.g files that it generated.

  • That worked DC! Thank you Sir!!!

Log in to reply