Warranty replacement fried?

  • I just tried configuring my warranty replacement and everything was working fine until I tried heating the bed and now the board will not turn on the led's will only turn on with the usb connection.I tested the power terminals for the main power and they are reading 1.9v instead of the 13.4v the psu is currently reading.I just replaced the heatbed and entire hotend and all the wiring for both.I don't know if you rememebre me but this just happened to me with my new board from Filastruder.

  • administrators

    @siblues said in Warranty replacement fried?:

    I tested the power terminals for the main power and they are reading 1.9v instead of the 13.4v the psu is currently reading.

    Do you mean that you have 1.9V across the VIN terminals of the Duet, but 13.4V across the terminals of the PSU that is supplying is? If that's what you mean, it can only be the result of a problem in the cable between the two, or you haven't tightened the VIN terminal block screws.

  • Yup that is what I am getting with no led's turning on whatsoever on the duet but they do turn on with the usb.I have removed the cables and tested the psu and it is at 13.4 and if I remove the cables from the duet they also show 13.4 but when they are installed into the terminals and checked with the psu on they show under 2v.

  • Can you post pictures, where from exactly you measuring this voltage and how your wires are connected to Duet?

  • I am checking voltage at the power in terminals in this picture.

    power wiring

  • Looks to me that your + wire at power terminal is not fully inserted. Please recheck that wires are in good contact with terminal and properly tightened.
    Am i understand you right : with psu connected to duet and powered up you have less than 2 v on duet power terminal but over 13 v on psu terminal same time?

  • Yeah I saw that the reason it is installed like that is because the first few times they were pushed in as far as they could go and it still wasn't working so I made sure the plastic on the terminal was not interfering with the connection.I can try to reinstall them again but I have done it 4 or 5 times already with no luck.The board was working fine while I loaded my config and updated the firmware.I then tested the fans and configured them and everything was ok and when I tested the bed the board shut off and didn't turn back on.The bed reads .9ohms it is a bit low but I don't see that being the problem.This is how the leds are behaving when using the usb.

    USB Led's

  • administrators

    @siblues, after removing the lead, unscrew the terminal screw a lot before you push it in again. Sometimes the wire can get trapped underneath the rising clamp instead of above it.

  • I just removed the cables and reinstalled them and still no luck here are two pics of the wires screwed into the blocks.Sorry about the poor quality of the pics.

    1st power wire

    2nd power wire

  • Do you think there could be a problem with the actual terminal block?

  • What is the resistance saying between the terminal the wire end attached to the power supply?
    If there is a connection issue between the terminal and the cable this could give you a hint

  • @siblues said in Warranty replacement fried?:

    Do you think there could be a problem with the actual terminal block?

    I have a few ideas, assuming the cable is properly inserted into the terminal and attached to the PSU. This is one - if possible, check the soldering on the underside of the board, and make sure it isn't cracked or lifted.

    Another is a possible short. From what you've posted, I think you've measured the voltage at the PSU while it's connected to the board, and the board is powered up. However, if your 13.4V PSU measurement was taken while the board is off or disconnected, but the board shows 1.9V once it's powered on, recheck the PSU in that state. If it is now showing 1.9V, that implies a short on the board or in the cabling, and the PSU is dropping into a fault condition to protect itself. Cycling the AC power or disconnecting the load should reset it.

    One more thought - is the power cable direct from the PSU to the Duet, or is there a switch between the two? (It may seem odd to switch the 12V, but there could be valid reasons.) If there's a switch, bypass it.

    As @crynool suggested, check the resistance of the power cabling itself. It, or a crimped-on terminal/ferrule, may be damaged.

  • administrators

    @siblues said in Warranty replacement fried?:

    Do you think there could be a problem with the actual terminal block?

    Where are you measuring the VIN voltage on your Duet with the multimeter? I normally touch the multimeter probes on the tops of the screws in the terminal block. That way I know that I am measuring the voltage that is reaching the Duet terminal block.

  • I am checking on the screws.i checked the PSU both connected and disconnected from the Duet and it reads 13.4 both ways.I don't have a switch between the Duet and PSU and the cables are a continuous piece of 10awg cable with the crimp connectors on both ends.I will check the resistance now and get back to you I will also check the solder joints on the terminal block.I don't think it is a wire issue because it was working fine and it wasn't moved at all and when the bed started to heat the Duet turned off and we have the current problem which kind of seems like a failure of some sort.

  • I totally removed the board and psu from the printer and used a new set of power wires and made sure they were installed into the block correctly and it still doesn't power on.I also checked the terminal block connections to the board and continuity from the screw to the soldered pins on the board are fine.I looked at the board and nothing that I can see shows any physical damage.I also checked the VSSA fuse and it is giving me a reading of .9-1.0 ohm.Anything else I can check?

  • Start with removing all cables/wires, just let the ones connected which you need to control the Duet (if it is Wifi, even better) & power.

    Just to make sure no other wire is creating a short (which isn't enough to blow a fuse but to have the PSU running in some sort of failsafe).

    What is the Amperage on that line when the Voltage is dropping?

  • That is what I just did the only wires connected to the Duet Wifi were vin and ground and it was reading less than 2v and the psu was supplying 13.4v.

  • Tried swapping the PSU? Sounds odd ... but apart from the Duet, this is the only piece which you didn't replace yet?

  • I ended up spending quite a bit more than I wanted to and a better PSU is on my list but I don't just want to throw money at the problem.i purchased the best when it came to the controller to try to avoid that in the first place.

  • I mean, at least you can try ... sort of cheap ATX PSU just for troubleshooting.

    Shorten PS_ON & GND, have an old HD Power connector connecting to VIN

Log in to reply