Error after firmware upgrade to 2.02



  • Hi,

    Just upgraded to 2.02 from 1.20 . All went smoothly and webpage came back up.

    Tried to home axis, and they are dead. Bed and hotend heaters are working.

    Here is the firmware log file ....

    3:55:23 AM: M122: === Diagnostics ===RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02(RTOS) running on Duet WiFi 1.02 or laterBoard ID: 08DGM-95BLL-N6PSS-6J1F6-3SN6T-KJUMKUsed output buffers: 1 of 20 (11 max)=== RTOS ===Static ram: 25524Dynamic ram: 98832 of which 0 recycledException stack ram used: 280Never used ram: 6436Tasks: NETWORK(ready,648) HEAT(blocked,1232) MAIN(running,3844) IDLE(ready,200)Owned mutexes:=== Platform ===Last reset 00:05:45 ago, cause: power upLast software reset at 2019-01-11 02:56, reason: User, spinning module GCodes, available RAM 3800 bytes (slot 2)Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f000 BFAR 0xe000ed38 SP 0xffffffff Task 0xffffffffError status: 0Free file entries: 10SD card 0 detected, interface speed: 20.0MBytes/secSD card longest block write time: 0.0ms, max retries 0MCU temperature: min 21.7, current 25.5, max 25.7Supply voltage: min 12.3, current 12.3, max 12.5, under voltage events: 0, over voltage events: 0, power good: yesDriver 0: standstill, SG min/max not availableDriver 1: standstill, SG min/max not availableDriver 2: standstill, SG min/max not availableDriver 3: standstill, SG min/max not availableDriver 4: standstill, SG min/max not availableDate/time: 2019-01-11 03:55:21Cache data hit count 1298551694Slowest loop: 2.76ms; fastest: 0.07msI2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0=== Move ===Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0Scheduled moves: 0, completed moves: 0Bed compensation in use: noneBed probe heights: 0.000 0.000 0.000 0.000 0.000=== Heat ===Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1=== GCodes ===Segments left: 0Stack records: 1 allocated, 0 in useMovement lock held by nullhttp is idle in state(s) 0telnet is idle in state(s) 0file is idle in state(s) 0serial is idle in state(s) 0aux is idle in state(s) 0daemon is idle in state(s) 0queue is idle in state(s) 0autopause is idle in state(s) 0Code queue is empty.=== Network ===Slowest loop: 22.68ms; fastest: 0.00msResponder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)HTTP sessions: 1 of 8- WiFi -Network state is runningWiFi module is connected to access point Failed messages: pending 0, notready 0, noresp 0WiFi firmware version 1.22WiFi MAC address 2c:3a:e8:0a:f5:c2WiFi Vcc 3.30, reset reason Turned on by main processorWiFi flash size 4194304, free heap 27816WiFi IP address 192.168.0.85WiFi signal strength -61dBm, reconnections 0, sleep mode modemSocket states: 0 0 0 0 0 0 0 0
    3:50:24 AM: G28 X S2: Error: G0/G1: insufficient axes homed
    3:50:15 AM: G28 S2: Error: G0/G1: insufficient axes homed
    3:50:06 AM: G28 X: Error: G0/G1: insufficient axes homed
    3:50:03 AM: G28 Y: Error: G0/G1: insufficient axes homed
    3:50:00 AM: G28 Z: Error: Must home these axes:XY before homing these:Z
    3:49:57 AM: G28: Error: G0/G1: insufficient axes homed
    3:49:47 AM: Connection established!
    3:49:32 AM: Disconnected.
    3:46:51 AM: G28: Error: G0/G1: insufficient axes homed
    3:46:47 AM: Connection established!
    3:46:46 AM: Page Load complete!

    Ideas please ?

    Thanks
    Keith


  • administrators

    When upgrading firmware, you should always read the upgrade notes for the new version and any versions you skipped, to see what changes you may need to make to config.g, homing files etc.



  • I Followed them to letter.

    I have made no config changes at all.

    Web control, wifi and main firmware all updated and report ok, as per the file above.

    I'm at a loss.



  • Too tired to check this all again now... It's 4.21 am.

    I'll try again tomorrow. Maybe there will be people with some constructive hints.


  • administrators

    I'm not going to spoon feed you, nobody would read the upgrade notes if I did that for everyone. Read the version 1.21 upgrade notes. https://github.com/dc42/RepRapFirmware/blob/dev/WHATS_NEW.md



  • Good Morning.

    Oh, you meant the individual release notes. Now I understand what you meant. After wading through the one page listing what to do in what order depending on what revision of software you're upgrading from and too, and it being late ( for me ) it didn't occur to me that each release had it's own readme file. My bad.

    Dave, the Duet is a great product. The Duet info wiki is expansive. And comprehensive. ....

    My two cents though, less words and more pictures / flow charts.

    Yes, the Duet is a technical product. But, page after page of 'do this IF, and in this order IF, else do this' doesn't always suit the audience.

    I am always happy to read and learn/self help, and I hope I don't need spoon feeding (for a few years yet).

    I have 5 original (non clone) Duet Wifi in machines with different setups that I have to upgrade. So, there is a point where it becomes a chore to read page after page of info. Last night it became exactly that.

    All this, combined with lack of sleep and the late hour caused my snippy response. My apologies.

    .....now, off to go find the reading glasses.

    Keith



  • I get this error message: "Error: G0/G1: insufficient axes homed"
    Recent firmware versions do not allow axes to be moved before they have been homed. The only movements allows are homing moves (G1 moves with S1 or H1 parameter) and individual motor moves (G1 moves with S2 or H2 parameter). So any Z movements that your homing files make before Z is homed should use the S2 parameter. Alternatively, add M564 H0 to config.g to allow axis movement before homing.

    https://duet3d.dozuki.com/Wiki/FAQ


  • administrators

    @phaedrux said in Error after firmware upgrade to 2.02:

    I get this error message: "Error: G0/G1: insufficient axes homed"
    Recent firmware versions do not allow axes to be moved before they have been homed. The only movements allows are homing moves (G1 moves with S1 or H1 parameter) and individual motor moves (G1 moves with S2 or H2 parameter). So any Z movements that your homing files make before Z is homed should use the S2 parameter. Alternatively, add M564 H0 to config.g to allow axis movement before homing.

    https://duet3d.dozuki.com/Wiki/FAQ

    Thanks, I forgot that we had an FAQ entry about this too.



  • Thank you for this.... I was just reading, changing and testing.

    I am concerned though. I have not moved this machine physically, and with the new firmware the WiFi keeps dropping out mid saving of config files. The router is maybe 30 ft away ( up one floor ). Signal level is -62db.

    Thoughts ?


  • administrators

    Which DuetWiFiServer version were you using before, and which version are you using now?



  • I am using 1.22 now ... was 1.20 prior ( I think ... I didn't check the revision. But, machine h
    as not been upgraded since July last year ).


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.