HELP! Think i screwed up my Duet :(



  • Story summary:
    Upgraded the firmware on my new card (v1.04) and set up the WiFi (completed)

    Then I tried to wire it up with a 24V + a stepper motor to try out the motion. But I couldn't get connected to the WiFi.

    So I unplugged everything, only plugged in a 5V. and then I saw a red light under the work Z Stop (See photo)
    My WiFi doesn't light up anymore.
    I also tried to connect to YAT and it doesn't work anymore!!!

    I plugged in to an older board to compare, attached in photo too.

    Save me 😞 Please tell me I didn't destroy the board.

    On my ok board:
    1_1547372799050_what it should actually be v1.03.jpg

    On my not ok board.
    0_1547372799048_something wrong v1.04.jpg

    I don't really dare to try anything on my other board already. in case I screw up one more time.



  • One more thing: the now faulty board heats up quite a bit


  • administrators

    Im sorry to hear that you are having trouble getting your Duet working. Which component or components are getting hot?



  • I think it is the big squarish IC (that's the CPU right?) anyway, I do think I have accidentally short circuit the board 😞 probably that explains why. maybe a nice insulated case will be a good add on 😂 😂 😂
    thanks for replying me though! always appreciate it!


  • administrators

    Yes the big square chip is the CPU.

    What do you think you shorted? If it was one of the I/O pins then it's likely that just the CPU is damaged, and it can be replaced. OTOH if you shorted +3.3V or +5V to VIN, then it's likely that multiple components are damaged.



  • I feel embarrassed telling you this... but I actually placed the board on top of my power supply (now you can tell how much of a complete electrical noob I am)☹ ☠ ☠
    So I actually have no idea what has/have shorted.


  • administrators

    It's hard to know whether it's just the CPU that's been damaged, or other components too. If the blue LED on the WiFi module turns on as soon as you apply power and stays on, then it's likely that at least the WiFi module is damaged too.

    It's a long shot, but you could try erasing the firmware, by fitting the Erase jumper and applying USB power for a few seconds. Then remove the jumper, connect to a PC via USB again, and see whether the Bossa port appears.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.