IR probe+Duetwifi - only digital mode



  • Hi,

    I've been using my IR probe quite successfully, but recently, i'd say out of nowhere, it only started working in digital mode (=2 flashes = no slow down when close to bed). It doesn't actually affect how my corexy's bed gets leveled, however i'd prefer the potential increased accuracy with the slow down. Is there anything I could do/troubleshoot ? I have 3 wires connected as suggested in the manual and, strangely, it did work recently and now it isn't.

    Thanks


  • administrators

    @randomfactoid said in IR probe+Duetwifi - only digital mode:

    Hi,

    I've been using my IR probe quite successfully, but recently, i'd say out of nowhere, it only started working in digital mode (=2 flashes = no slow down when close to bed). It doesn't actually affect how my corexy's bed gets leveled, however i'd prefer the potential increased accuracy with the slow down. Is there anything I could do/troubleshoot ? I have 3 wires connected as suggested in the manual and, strangely, it did work recently and now it isn't.

    Thanks

    1. Check your M558 command in config. You should be using P1 in that command. Most other choices will enable the pullup resistor on the Z probe input, which will cause the sensor to start up in digital mode.

    2. The other possibility is that something is causing your Duet to startup very slowly, so that the M558 command isn't executed until the IR sensor has initialised. If you have any commands in config.g that are likely to take along time to execute, put the M558 command earlier in config,g than those other commands.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.