Duet 2 Wifi Issues



  • Hi! I'm a new Duet 2 Wifi customer and user. For what I've been able to experience so far, it's a great little board.

    I seem to be having some difficulty now. I installed the board on an Openbeam KosselPro and configured it yesterday. I had installed all of the components and had the unit up and running, on wifi, for a single 20mm calibration cube print. Everything calibrated well with the Mini-IR for bed leveling, heated and read temperatures well, and printed solidly with no issue. Best and easiest print I ever completed.

    My configuration is:

    • X,Y,Z limit switches - discrete micro-switches (new Molex)
    • NEMA 17 stepper motors for X,Y,Z,E0 (single extruder) (old dupont)
    • Creality CR-10S Pro double gear extruder
    • PanelDuet (new molex)
    • 24V power supply wired to the board (voltmeter tested @24.09VDC) (wires under terminals)
    • Mini-IR Z-Probe (@Spool3D) (new Molex)
    • E3D V6 hotend & thermistor & 24VDC 30mm fan (new Molex)
    • KosselPro HBP hotbedw/ thermistor (old dupont)
    • 2 additional 30mm fans connected to PWM Fan0 and Fan1 (new Molex)

    The challenge comes now where I had the unit turned off for ~14 hours (overnight) and then turned it back on to begin a print. It would not communicate, connect to USB and connect a port, and lost the 3V LED when turned on main power. I used the on board mains power supply for the 5V and 3V supply (default config).

    I've disconnected everything, rechecked every connection, followed all the troubleshooting guides.... The PanelDuet powers up too but doesn't connect to the board.

    Have you seen this before? Is there something in the diagnostics I've missed? I sense as I've seen in some other posts that it's the 24VDC to 3.3/5V short scenario - but I struggle with how this is possible. All of the connections I've made are new or old dupont style as noted above.

    Any assistance you could provide would be appreciated. It looked so promising!

    I'd also emailed my vendor (Spool3d) to get some assistance.

    Cheers,
    Daniel


  • administrators

    I'm sorry to hear that your Duet has stopped working. I'm happy to approve a warranty replacement. Please direct Spool3D to this post.

    Is there are sign of damage to the small square chip labelled U3? we've hads a few reports of them failing recently (after having zero recorded failures for the previous 2 years).



  • Hello Sir,

    I took a good look at U3 and U2; both do not have visible signs of damage. U3 has all chip markings still clearly visible and U2 is still clear and shiny (no heat damage discoloration).

    I put a voltmeter on a 3.3V pinout to ground and measured ~1.3VDC while powered from the USB. I neglected to test with power from mains.



  • Hi there again,

    I received the replacement board this afternoon and installed it, taking great pains to ensure I followed the guides. Instead of using the onboard power supply for the 5V - I decided not to tempt fate and use an external 2 wire 5VDC 2A wall plug and moved over the jumper as directed.

    All went well and the printer began printing a calibration cube again. I cancelled the print through the web interface knowing the settings in the config file hadn't changed and I had dialed it in before.

    Eager to attempt a full print - I loaded a basic file and the board now does very weird things.

    Here is the sequence of events that fell afterward:

    • The X driver blinked out during the home call - mid way up the rails.
    • Shut down the board,
    • Unplug the motor leads, and reset the position of the arms to the top of the printer
    • plug in, restart - no X LED comes on.
    • power-down - wait a bit while reading forums
    • turn on 5V the 24VIN - all LEDs - YAY!
    • call for home - printer rams to the top and keeps driving
    • turn off VIN (driver power) but leave board on
    • test limit switches - now when each limit switch is pressed, the GUI says its active, but the corresponding driver LED blinks out.

    I ran
    M584 - Driver assignments: X2 Y1 Z0 E3, 3 axes visible comes back
    M906 - Motor current (mA) - X:1000, Y:1000, Z:1000, E:800, idle factor 30%
    M92 - Steps/mm: X: 80.000, Y: 80.000, Z: 80.000, E: 139.560

    Don't tell me I've two bad boards in a row...

    are there other jumpers or pins I should be checking?

    Disappointed.
    Daniel


  • administrators

    If you are using normally closed limit switches as recommended, the endstop LEDs should be lit when the switches are NOT triggered. So that part is normal.


  • administrators

    You have an unusual drive assignment, XYZ mapped to 210 instead of 012. I suspect that you don't have the motors and endstops assigned to the corresponding towers. Label your towers X on the left, Y on the right, Z at the back. Then test that when you trigger the X endstop, the X endstop shows as triggered in M119 or the Machine Properties page of DWC. Same for Y and Z. Then use G91 and G1 S2 moves to test the X, Y and Z motors individually and make sure that the correct motor moves each time. See the wiki page on configuring RRF for a delta to see how to do individual motor moves.



  • Solved.

    I reconfigured the machine as detailed and yes, the configuration was off. I also re-worked the RFF per the delta config as suggested. I didn't change much but tweaks were helpful.

    Currently 12 hours of print time on the machine and things appear to be working.

    Thanks for the support. It's been clear, instructive, and direct.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.