G92 outside axis limit resets positon to limit



  • I have quite complicated homing files because my hotend can move outside the bed but I don't won't to move it during print outside the bed.
    But at homing Z I need to move outside the bed, I am using just M564 S0 H0 to allow to do that. And when in homing Z I run G92 Z0 it resets Z position from 307 to 290...

    Simple steps to reproduce:

    1. home all axes
    2. run M564 S0 H0
    3. move outside axis limit with X or Y
    4. run G92 Z0

    Even putting something like that G92 Z0 Y307 when Y axis is limited to 290 will lower Y to 290.
    And I think this behavior can stay but not when you run M564 S0 H0. When axis limits are disabled they should not by applied to G92 commands too.



  • Instead of M564 command i would use M208 to temporary expand axis limits and after homing you can always set limits back to bed area.



  • Yeah I could do that too, for now I just move outside the restricted area before running G92 Z0.
    But I still this should be changed or documented, it took mi two hours to find out what is wrong with my homing files 😂


  • administrators

    This fault has been reported before, and is already fixed in my latest internal build.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.