pause.g & resume.g with filament runout - temperature



  • I think there is a simple solution for this - but I could not find the answer to my question. Maybe someone can help me.

    I have configured a mechanical switch as a filament runout sensor:

    ; Filament Run Out Sensor
    M591 D0 P1 C4 S1 ; Filament runout Sensor for Extruder E0 on E1 Endstop input

    Everything works fine. But I want to fine tune it a little bit.
    Correct me if I am wrong. But if "no filament" is detected, the printer calls "pause.g" and after I loaded new filament I can continue the print using "resume.g".

    Sometimes the Filament runout triggers while I am at work or sleeping....is it possible to turn of the corresponding heater after a certain amount of time so the filament won't "cook" in the hotend ? Like the Prusa MK3 does.
    Maybe it would be possible to just switch between idle temp ("0 degree C") and "active" temp.

    Thanks for your help 🙂


  • administrators

    One option is to put a T-1 command in your pause.g file after parking the head at the pause position. This will deselect the tool and it will be allowed to cool to standby temperature. Start your resume.g file with T R1 followed by M116 to heat it up again.


Log in to reply