Delta mesh leveling with warped result



  • I managed to fully configure my Kossel Plus, up to having Auto Delta calibration (with a fixed BLTouch) work perfectly.
    I even succesfully printed some objects without issues.

    I wanted to try mesh leveling, but I always get the following result after all the probes:

    0_1548548723399_Annotation 2019-01-27 011542.jpg

    What could be the issue?
    Including my config.g & bed.g:

    1_1548548684464_config.g 0_1548548684463_bed.g

    Thanks for any help!



  • @gtrevi

    In your bed.g file there is this line:

    G30 P10 X0 Y0 H0 Z-99999 S3

    Why are you using S3 for a delta? I think S6 would be more appropriate.

    Also I don't see a M500 to save the results and the M501 in your config.g file is commented out.

    Can you elaborate on what you are doing there?

    Frederick



  • @fcwilt thanks for pointing out raising the S parameter, definitively better option (was just using the auto-generated bed.g from the RepRap configurator).
    But unfortunately raising to S6 (also tried S9) did not have any effect on the above result.

    Regarding the M501 commented out in the config.g, it's simply because I prefer to have all values reported in the main config, rather than having an override file... but i new to Duet & RepRap, so might be doing something wrong: is it obbligatory to M500 & M501?

    Gianni



  • @gtrevi said in Delta mesh leveling with warped result:

    Regarding the M501 commented out in the config.g, it's simply because I prefer to have all values reported in the main config, rather than having an override file... but i new to Duet & RepRap, so might be doing something wrong: is it obbligatory to M500 & M501?

    Gianni

    No you don't have to use the override file - it's just simpler to let the firmware maintain the two files.

    Initially I felt as you do but then after sometimes failing to update the config file when the override file was updated I started using the two files as designed.


  • administrators

    Assuming that you have set your rods length correctly in M665 and your tower steps/mm correctly in M92, your delta radius setting in M665 is a very long way out. Run auto calibration with either S4 or S6 and save the resulting M665 and M666 values. If you still have problems after that, post your config.g and bed.g. files.



  • @dc42 super, you nailed it again: I was "a bit off" with the delta radius.
    Thank you very much! 🙂



  • @fcwilt good point, thank you!

    You're right, especially at the beginning, when you're always hands-on with configs, it doesn't help scattering around with all the updating here and there, in place of a simple M500.
    On the other side though, you learn a lot about what you're doing, which isn't bad 😉

    Now that my delta is all fine tuned, I will start relying on this suggested practice of yours for any other further tweak I may need in the future.

    Thanks
    Gianni



  • @gtrevi

    Glad to hear you got it all sorted out.

    Frederick


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.