Duet2 WiFi non-responsive on 12v or USB after first test



  • I just got my Duet2 WiFi and got it all wired up and configured according to the official guide. I updated the firmware from 2.01 to 2.02 and everything appeared to be working well. I decided to start slow with testing and set it to just heat E0 to 180. Right around when it came to temperature I noticed the E0 fan turned off. I looked at the board and saw that only the VIN LED was on now. I immediately killed the main power and powered back up and it returned to the exact same state.
    I disconnected main power and tried connecting via USB to pull diagnostics and my computer gave me a Power Surge on USB port error (on a USB 3.0 port). I also noticed that some of the LEDs for the motors looked like they were trying to light up when I plugged in the USB.
    I disconnected everything from the board, restarted my computer, and connect via USB again and got the same power surge error on my computer, now on a powered USB port on my laptop dock. The only LEDS that come on when I connect via USB are Diag, USB, 3.3V, and 5V+. They then slowly fade out, assuming this is from my computer cutting power to the USB port.
    I have tried resetting the board with the reset jumper and checked all the fuses but nothing has improved. It seems like it is trying to pull the full board power from the USB. I'm not sure if this could be a USB ground loop issue or something. Is there anything I can do to remedy this or is the board bricked and need to be RMA'd?



  • I'm no EE but have a little electrical knowledge and have been carefully examining/testing components that I can. I found that while the USB is plugged in R37 and D13 are getting much hotter than their surrounding components. I pulled power when they started to go past 60 C.
    I checked D13 and got a forward bias of 0.19V and reverse bias of OL, so it looks good. I did notice when I measured R37 I got 18.78K when I had my probes setup to match the anode/cathode markings for D13 (power flowing away from the USB port), but got 26.42K when I reversed my probes.
    I checked some of the other diodes on the board and got normal forward bias readings but got reverse bias readings of 0.975V on the diodes around the endstop and fan connectors. I tried to short all the caps I could but I'm assuming this reading must be from a cap(s) I missed.
    I also tried a variety of USB cables and had the same experience with all of them. I'm not entirely sure how to test further. I have put in a RMA request with the re-seller I purchased my board from as I feel there is a short somewhere that I will not be able to fix myself.


  • administrators

    I agree, looks like there is a short somewhere. Try removing the SD card in case it's that.

    R37 is 27K so the reading you got was correct. It was probably pickling up the heat from D13.



  • Thanks for the reply! I had tested it with and without the SD card and had the same issue. The reseller happily processed an RMA and even offered advanced replacement. I got the new board wired up (double checking all my connector polarity) and things appear to be working great on the new board.



Looks like your connection to Duet3D was lost, please wait while we try to reconnect.