Temperature control acting wierd



  • Here is a clip from during one of my prints that stopped do to a heater excursion:
    0_1548609058161_02164751-929a-4c16-8dae-8527bc51ddff-image.png
    The readings seem to be jittery but its not consistent. Just sometimes during a print this happens. I thought if it was a loose wire on the thermistor then it should be happening consistently and as far as I can tell the thermistor is tightly secured in the heater block. I am using an E3D V6 hotend with the cartridge style thermistor. I am wondering if anyone else has seen this and know why. Also I'm running RepRap firmware 2.02 and the latest Duet Web Control release.

    Thanks



  • I had a bad e3d v6 thermistor that caused all sorts of print quality issues. Replacing the thermistor solved the problem instantly.



  • I will try replacing it then. Also it seems to only happen while printing and not when I just set a temp and leave it for like changing filaments or something like that. Maybe its movement induced.



  • Does it coincide with the part cooling fan coming on? Do you have a silicone sock for the heat block?



  • HI

    I have something similar, see post:
    https://forum.duet3d.com/topic/8778/troubleshooting-hotend-temp-signal/9

    I have changed the thermistor, some prints like calibration cube work well.
    But now even with heated Hot end performing a G32 or G29 I see the spikes.

    I also tried the G29 with BED off and still bad signals and strange height map with pikes in it. Tried with a clean glas bed and still the same sh..

    Next step, routing a spare cable for the thermistor and test, but I am quite sure this won't help.

    Is there a possibility that the board loads some capacities?


  • administrators

    Downward-going spikes in the temperature graph when using a thermistor as the temperature sensor normally indicate a bad connection in the thermistor wiring. Another user just had this problem, see https://forum.duet3d.com/topic/8778/troubleshooting-hotend-temp-signal/14.


Log in to reply