Duet WiFi Access Point setup problems



  • I'm able to setup the access point to work great but unfortunately I can't seem to get it to work unless I send M552 S2 command anywhere to 1-6 times after booting up. I created a macro which does make it easier but it would be nice to get it working without booting up, going into macro menu, hitting macro, checking connection, hitting macro again, checking connection, repeat....

    I've read through many other people having difficulty as well and I've tried so many combinations I can't remember them all. I just can't get past having to enter the M552 S2 command more than what is already in my config.g. I live where you can't get internet other than on my phone so I don't use a home WiFi network and have to set up the Duet WiFi as an access point (one of the main reasons I bought it).

    Machine: Tronxy corexy
    Controller: Duet WiFi
    Firmware: 2.02a
    Web control: 1.22.6
    WiFi server: 1.22

    Here is my configuration with password removed below but working fine so that isn't an issue.

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Wed Jan 23 2019 15:02:09 GMT-0900 (Alaska Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P"TronxyX5SA" ; Set machine name
    M552 S2 ; Enable as an access point
    M589 S"TronxyC5SA" P"nnnnnnnn" I192.186.2.100 ; Configure access point parameters. Set SSID, WiFi password, & IP address to use.

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E418.5 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z6000.00 E600.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z1000.00 E100.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X40 Y40 Z0 S1 ; Set axis minima
    M208 X330 Y330 Z400 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M574 Z1 Z2 S2 ; Set endstops controlled by probe
    M558 P5 I1 H5 F120 T6000 A10 R0.5 B0 ; Set Z probe type to modulated and the dive height + speeds
    G31 P500 X-30 Y-40 Z5.35 ; Set Z probe trigger value, offset and trigger height
    M556 S50 X0 Y0 Z0 ; Set orthogonal axis compensation parameters
    M557 X55:330 Y65:330 S15 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 B4725 C7.060000e-8 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S300 ; Set temperature limit for heater 1 to 300C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory


  • administrators

    Remove the M589 command from your config.g file and try again. It only needed to be sent once, the parameters are stored in the WiFi module.



  • I tried removing M589 with no change. I tried M588 and then re-tried setting up the network again. I also tried M552 S0 followed by M552 S2, which I believe I saw in some other earlier firmware version posts with people trying to get access point mode working.
    The Duet 2 WiFi still needs M552 S2 command entered after boot up in order to run and more often than not it needs the command sent several times. The Paneldue is great to have so that the macro is easy to use without having to physically connect through USB and use YAT to send the command.
    Duet WiFi running as an access point works great without any problems, dropped signal, or errors once I can actually connect.


  • administrators

    Try connecting a PC or laptop to the Duet via USB, running YAT or Pronterface. Send M111 S1 P14 to enable WiFi debugging. Then try sending the M552 S2 command (from USB or PanelDue, it doesn't matter). If it fails to start up as an access point, let us know what debug messages if any it sends to the PC.



  • If it isnt typo, then change your IP address. 192.186.2.100 is known static IP of some server and shouldnt be used by anyone else. You probably want to use 192.168.2.100



  • @aidar said in Duet WiFi Access Point setup problems:

    If it isnt typo, then change your IP address. 192.186.2.100 is known static IP of some server and shouldnt be used by anyone else. You probably want to use 192.168.2.100

    I changed it to 192.168.2.100. This did not change the problem I'm having.



  • @dc42 said in Duet WiFi Access Point setup problems:

    Try connecting a PC or laptop to the Duet via USB, running YAT or Pronterface. Send M111 S1 P14 to enable WiFi debugging. Then try sending the M552 S2 command (from USB or PanelDue, it doesn't matter). If it fails to start up as an access point, let us know what debug messages if any it sends to the PC.

    Here are my current network settings after the changes recommended:
    ; Network
    M550 P"TronxyX5SA" ; Set machine name
    M552 S2 ; Enable as an access point

    And the report from YAT when enabling WiFi debugging. I'm not sure what the M596 warning is about. I don't have that command in my config.g

    RepRapFirmware for Duet 2 WiFi/Ethernet Version 2.02(RTOS) dated 2018-12-24b1<LF><LF>Executing config.g...Warning: M596 command is not supported<LF>Warning: Heater 1 appears to be over-powered. If left on at full power, its temperature is predicted to reach 606C.<LF><LF>Done!<LF>RepRapFirmware for Duet 2 WiFi/Ethernet is up and running.
    m511 s1 p14
    M511 command is not supported<LF>ok<LF>
    M111 S1 P14
    Debugging enabled for modules: WiFi(14)<LF>Debugging disabled for modules: Platform(0) Network(1) Webserver(2) GCodes(3) Move(4) Heat(5) DDA(6) Roland(7) Scanner(8) PrintMonitor(9) Storage(10) PortControl(11) DuetExpansion(12) FilamentSensors(13) Display(15)<LF>ok<LF>
    M552 S2
    ok<LF>WiFi reported error: Failed to start access point<LF>WiFi module is idle<LF>
    M552 S2
    ok<LF>WiFi reported error: Failed to start access point<LF>WiFi module is idle<LF>
    M552 S2
    ok<LF>WiFi reported error: Failed to start access point<LF>WiFi module is idle<LF>
    M552 S2
    ok<LF>WiFi reported error: Failed to start access point<LF>WiFi module is idle<LF>
    M552 S2
    ok<LF>WiFi reported error: Failed to start access point<LF>WiFi module is idle<LF>
    M552 S2
    ok<LF>WiFi module is providing access point TronxyX5SA, IP address 192.168.2.100<LF>


  • administrators

    OK, leave it with me - I'm having problems starting AP mode too.



  • @dc42 Thank you. Just let me know if you need me to try anything else. The Duet WiFi is so much superior and configurable to what I had I'll live with my current process of hitting my macro a few times for now. With the awesome Paneldue at least I don't have to connect USB to send commands.


  • administrators

    @AKLiving, please try installing DuetWiFiServer.bin version 1.23beta1 from https://www.dropbox.com/s/gkb6rulcayiqjcm/DuetWiFiServer.bin?dl=0 and let me know whether it fixes the problem.

    If you need to use YAT to get debug info, go to Settings->Text settings and set the line ending to <LF>. That will result in better formatting of the debug info.



  • @dc42
    After 2 reboots it is now working. It allows me to have 2 devices connected at the same time too! (iPhone and laptop with win10) I’ll cycle it a few more times on Monday and let you know how it’s going.


  • administrators

    Thanks, I'll wait to hear from you again.



  • @dc42 It has been working without a single failure to connect. Thank you very much.


  • administrators

    Thanks for the feedback. I included this version of DuetWiFiServer with the RRF 2.03beta1 release. So anyone else having the same problem can pick it up from the 2.03beta1 release area.



  • @dc42 said in Duet WiFi Access Point setup problems:

    Thanks for the feedback. I included this version of DuetWiFiServer with the RRF 2.03beta1 release. So anyone else having the same problem can pick it up from the 2.03beta1 release area.

    I'm having similar problems with AP mode:
    on every reboot
    I need to open Pronterface,
    force M552 S0,
    force M552 S2 a few times (normally 3),
    than AP mode goes on and everything works.

    I'm on latest stable, 2.02.
    I also tried to add
    M552 S0
    G4 S5
    M552 S2
    in config.g, thinking it may be a question of time to wake up for AP mode. No joy.

    So:

    • should I update to 2.03beta1 or 2.03beta2?

    • should I update DuetWifiServer.bin only, or Duet2CombinedFirmware.bin too?

    My config.g and SETNETWORK macro attached
    thanks!

    0_1551155432746_config.g
    0_1551155466497_SETNETWORK.txt


  • administrators

    If you want to stay on firmware 2.02 then you can just upgrade DuetWiFiServer to version 1.23beta.



  • @dc42 thanks!
    I installed DuetWifiServer.bin AND Duet2CombinedFirmware.bin, 2.03beta1 (I installed before reading your answer!),
    kept
    M552 S0
    G4 S5
    M552 S2
    and now access point mode works good!


Log in to reply