retraction problem



  • i got the same problem than this poste perfectly the same issue
    https://forum.duet3d.com/topic/4957/retraction-issues

    im comming from repetier-host, im kind of lost a bit haha
    i cant figureout the thing...

    im thinking to but back my old mks gen 1.1 i was printing almost prefectly
    printer tronxy x5s bondtech extruder (still bowden) fang part cooling the rest complete stock

    i change the controller (put a duet 2 maestro) to get the hair i miss to perfection and got network control , and 2 week later i cant even print a 20 test cube close to ok. my problem is the retraction it just stop to retract and stop to unretract and restart i let a blob each time on undo retraction, i got it better with the M555 P5 but still take a pause. direct connection to repetier host or simplify3d do it but get a better job than direct g code loaded

    here my config
    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P5
    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P"Jp Killer X5S" ; Set machine name
    M552 P192.168.50.22 S1 ; Enable network and set IP address
    M553 P255.255.255.0 ; Set netmask
    M554 P192.168.50.1 ; Set gateway
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S1 r8080 ; Enable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X32 Y32 Z32 E32 I1 ; Configure microstepping with interpolation
    M92 X159 Y159 Z799.180 E815.00 ; Set steps per mm
    M566 X3000.00 Y3000.00 Z400.00 E800.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z1000 E1500 ; Set maximum speeds (mm/min)
    M201 X3000 Y3000 Z200 E10000 ; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z1100.00 E1100.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X330 Y330 Z400 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M558 P0 H5 F900 T18000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:215 Y15:195 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R2200 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R2200 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P1 S1 I0 F15 H1 T50 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P0 S0 I0 F15 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F4000 H0 T30 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured
    M307 H1 A207.2 C79.9 D4.4 V12.2 S1 B0

    can some help me please


  • administrators

    Please post the GCode file you are trying to print on a Dropbox, Google Drive or another public file sharing site, and post a link to it.



  • i can give you almost all the try i did , i made 82 20mm test cube different slicer, different setting i will try to upload some soon

    tank's for your fast answer


  • administrators

    Also please check which firmware revision you are running, and upgrade to 2.02 or 2.02a if you are not already running it.



  • https://mega.nz/#F!nJNHWQ5A!m-ZgHKV4KH3Oo53iZPmrBw

    Software Information
    Firmware Name: RepRapFirmware for Duet 2 Maestro
    Firmware Electronics: Duet Maestro 1.0
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    Web Interface Version: 1.22.6


  • administrators

    Can you post a video showing the problem, when you print 20mmTestCube-repaired.gcode?

    The only issues I saw in that file were:

    1. You appear to have enabled retract on layer change, but not retract on travel moves. So you will probably get stringing on travel moves.

    2. There is a deliberate 500ms delay in the GCode file when changing from layer 1 to layer 2. It is immediately after the fan is turned on, so my guess is that it is intended to allow time for the fan to spin up. However, the filament is retracted at that point.

    3. Your maximum retraction speed is set to 1500mm/min in M203 which is 25mm/sec. That's quite slow. Retracting or repriming 5mm of filament will take a little over 0.2sec. Is that the duration of the "stop to retract" that you see?

    4. You have set your extruder acceleration very high (10000mm/sec^2) in M203. There is a high chance that your extruder is skipping steps and you are not achieving 5mm of retraction.



  • @dc42 i change so many thing that i need to check for that tonight for the accelration

    for my extruder skip is not the case bondtech do a prety good gob on that part the best upgrade ever lol it never happen from the time i put it


  • administrators

    @secretman said in retraction problem:

    for my extruder skip is not the case bondtech do a prety good gob on that part the best upgrade ever lol it never happen from the time i put it

    I'm not worried about the extruder losing its grip on the filament, I'm concerned about the inertia of the stepper motor.



  • @dc42 ok i got time for test hahah seam a lot better with the "jerk" seti this way no skipping im pretty shure i didint see an under or over extrusion seam i print 3/4 roll of 20x20x20 cube for a little parameter hahahhahahah

    tanks for all!!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.