M569 for choosing stealth chop is not working



  • If I do send

    M569 P0 S0 D3

    via console, I get the error message:

    Error: M569: Driver 0 does not support mode 'stealthChop'

    But the docs clearly say that the DUET uses TMC2660 and lists TMC2660 as stealth chop capable. Am I missing something?

    Im running the latest firmwares with a DUET + DUEX5:

    Firmwarename: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Elektronik: Duet WiFi 1.02 or later + DueX5
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.22
    Web Interface Version: 1.22.6



  • Stealth chop is for the TMC2224 drivers on the Duet Maestro.

    The TMC2660 drivers on the Duet 2 do not have stealth chop capability.



  • ah, thx for clarifying. Then, the docu is a bit misleading 😕

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M569_Set_motor_driver_direction_enable_polarity_and_step_pulse_timing

    Dnn (firmware 2.0 and later, only applies to TMC2660 and TMC22xx stepper drivers) Driver mode: 0=constant off time, 1=random off time, 2=spread cycle, 3=stealthChop or stealthChop2. The default is spreadCycle for TMC2660 drivers and stealthChop2 for TMC22xx. In stealthChop mode the drivers will switch over to spreadCycle automatically at high speeds, see the V parameter.



  • I updated the docs to clarify that mode 3 only applies to the TMC22xx drivers.


Log in to reply