stealthchop: "motor phase B may be disco..."



  • Seems like no matter how slow or gently I print, I always get these messages when using stealthchop

    maestro - 2.02


  • administrators

    1. Please check that you are using the 2.02 release firmware, not a 2.02RC version.
    2. What motor current have you set?
    3. Which motor or motors does the message mention?
    4. Is it only phase B that is mentioned, or is phase A sometimes mentioned too?
    5. What VIN voltage are you using?
    6. A link to the motor data sheet may also be helpful.


  • @dc42 2.02(RTOS) (2018-12-24b1), it will happen on any motor, but most often on Z, and either or both phases, VIN fluctuates between 24 and 25 even though I have a good meanwell 600W psu with feedback sensor.

    M906 X1400 Y1400 Z900 E1500:1400 I70; Set motor currents (mA) and idle current percentage

    XY: https://www.moonsindustries.com/p/nema-17-high-precision-hybrid-stepper-motors/ms17ha2p4200-000004611110015919
    2xZ: whatever crap came with the promega, I converted it
    E: https://e3d-online.dozuki.com/Document/120/.pdf


  • administrators

    Thanks. Please run M569 P0 to list the driver settings, then M569 P1 etc. up to P5. List the results here.



  • @dc42

    10:09:19 AMM569 P0
    Drive 0 runs in reverse, active low enable, step timing fast, mode stealthChop, ccr 0x00053, toff 3, tblank 0, hstart/hend/hdec 5/0/0, tpwmthrs 1 (4791.1 mm/sec)
    10:09:18 AMM569 P1
    Drive 1 runs in reverse, active low enable, step timing fast, mode stealthChop, ccr 0x00053, toff 3, tblank 0, hstart/hend/hdec 5/0/0, tpwmthrs 1 (4791.1 mm/sec)
    10:09:16 AMM569 P2
    Drive 2 runs forwards, active low enable, step timing fast, mode stealthChop, ccr 0x00053, toff 3, tblank 0, hstart/hend/hdec 5/0/0, tpwmthrs 1 (1890.3 mm/sec)
    10:09:15 AMM569 P3
    Drive 3 runs in reverse, active low enable, step timing fast, mode stealthChop, ccr 0x00053, toff 3, tblank 0, hstart/hend/hdec 5/0/0, tpwmthrs 1 (4039.1 mm/sec)
    10:09:14 AMM569 P4
    Drive 4 runs forwards, active low enable, step timing fast, mode stealthChop, ccr 0x00053, toff 3, tblank 0, hstart/hend/hdec 5/0/0, tpwmthrs 1 (4039.1 mm/sec)
    

  • administrators

    Thanks. You have tpwmthrs in your M569 commands set much too low on all drives. StealthChop is problematic at high speeds.



  • @dc42

    My initial post said, no matter how slowly or gently I print. I'm not trying to print at high speed when this happens.


  • administrators

    My guess is that stealthChop is using a very low motor current. Perhaps it hasn't calibrated itself to your motors very well. It normally does that calibration during the initial homing moves. It might work better if you change the speed of your homing moves.

    You could also try adding this at the start of homeall.g:

    G91
    G1 S2 X0.02 Y0.02 Z0.02
    G4 P100
    G90

    This moves all the motors a tiny amount, then pauses to give the drivers time to measure the standstill characteristics of the motors, before proceeding with homing.



  • @dc42 I've already been doing that. I don't home as part of my print process, I home manually.


  • administrators

    What do you mean by "I home manually"? If you mean that you press the Home button in DWC or send G28, that's fine. If you mean you push the axes to the right positions by hand, or do short jogging moves, that isn't, because stealthChop needs a long medium speed move to calibrate the motor.



  • @dc42 I click the home button. OK, I'll look at my init code to see if it meets your suggested.



  • @dc42 btw, I'm assuming I need an M564 H0 otherwise it won't move?

    G91
    G1 S2 X0.02 Y0.02 Z0.02
    G4 P100
    G90


  • administrators

    G1 S2 moves will work without M564 H0.


Log in to reply