mesh grid



  • hello,

    i am trying to get the mesh grid compensation running only i don't relay know what is happening.

    as shown in the picture my calibration is in a unusual shape and is 5 mm below the bed or something. right now it looks like a bowl or something like it.

    right now i am using a Duet 2 WiFi with Firmware Version: 2.01(RTOS) (2018-07-26b2) on a delta printer.

    i also uploaded some file's so maybe this helps
    3_1548884966351_retractprobe.g
    2_1548884966351_deployprobe.g
    1_1548884966351_config.g
    0_1548884966351_bed.g

    0_1548884793317_b7ae60ed-2d42-4b79-a100-d2b4cd092d28-afbeelding.png

    0_1548885202554_dfd3efe9-6708-41c3-be01-c836a639e1cd-afbeelding.png



    1. Consider updating your firmware to the latest version (2.02)

    2. Your probe offset in your G31 command (config.g) likely needs to be altered, although I can't remember whether it needs to be increased or decreased.. this should bring your bed map more in-line with plane.

    3. The reason you are seeing a dish shape is likely due to the delta effector tilting slightly as it moves around in XY. I don't run deltas so I'm not sure how to address this, but it would affect the trigger height of your probe. It is possible to change the bed.g file to apply trigger height modifications based on the individual G30 XY positions (this is the H value of the G30 command) but I'm not sure exactly how you would measure it to get good values...

    Side note, but consider using the M401 command to deploy probe and the M402 command to retract. This is the equivalent of the M98 Pdeployprobe.g and M98 Pretractprobe.g in your bed.g, but is a bit cleaner.


Log in to reply