Clearpath servomotor --> 50Nm --> suggestion



  • Not going to work, Clearpath has to have + and - connected to each function; enable, step and direction. You can download the manual at their site. Soo easy to just Clearpath wiring and power supply.



  • Manual --> OK.

    Just a quick review of your answer...Maybe we didnt understand us.
    I have 2 sets of those cables ( 2 pcs of 4 pin headers).
    I didnt do anything else accept extending the original cables without cutting the molex connector. This extension is just plugged in into existing molex connector ( with 1:1 color setup ).

    If i see correctly on your photo, inline connector is set without red and green wire.... Anyhow, i will take a look into manual 🙂

    Regards !



  • Hi !

    I tested the motor over USB and it worked perfectly.
    I also found the wiring part in the clearpath manual so everything is set for duet test.

    Wiring for one motor is as follows:
    Orange -> enable -
    Blue --> enable +
    Brown --> input A -
    White --> input A +
    Yellow --> input B -
    Black --> input B +
    Inline connector is wired to drive 5 of duets expansion board.

    OK. now what 🙂 🙂
    How to make some basic test from duet ?
    Do i need to add something to config.g file (M569 command), do i need any additional wiring ?

    At, the moment, motors are not connected to rotary delta robot and test will be made on one single motor.

    Best regards and thank you in advance for your comment !
    Arnix


  • administrators

    @arnix said in Clearpath servomotor --> 50Nm --> suggestion:

    Do i need to add something to config.g file (M569 command)

    Yes, you will need to add a T parameters to the M569 commands for the external drivers, which I presume are P5 P6 and P7. The Clearpath manual should say what values you need (they are step pulse width, step pulse interval, direction setup time, and direction hold time).

    Then send G91 and then G1 S2 commands to test the motors individually.



  • Not to much to set up the Clearpath, once it is installed run the auto calibration as per instructions. The other thing is steps, the Clearpath has a setting for frequency and config.g M92 has steps per mm. if the frequency is to high and the steps is too low the motor shaft appears to not move, if it is the opposite the motor will turn very fast. Since you are using a reduction gear experiment before attaching the gear box. You will probably want to start with the frequency setting at its lowest. I set my frequency so the steps is around two to three hundred. then dial in M92 to get the proper travel. You don’t have this capability with a stepper motor.



  • @dc42
    Hi David and thank you for replay.
    P5 P6 and P7 ... step pulse width, step pulse interval, direction setup time, and direction hold time


    So, basic setup should be something like this:
    M569 P5 S1 ;
    M569 P6 S1 ;
    M569 P7 S1 ;
    M569 P5 R1 T 2:2:5 ( need to be checked with manual )
    ... ?

    @Edkirk
    Autocalibration:

    • i run the auto calibration part with 70% peak and it completed without problems. Gearbox is running as it should. At 2500 rpm i get 100 rpm / minute on gearbox. Weight test is also passed ok ( tested with 3 kg on gearbox shaft ). Now, there is an option for setup acceleration but i dont know what is some minimal or maximal value. If i set some bigger or lower value, then some defined limit value, will this be automatically corrected in MSP ? I know its basic question but motor is too expensive to test it with try / fail option :-). At the moment i have 2500 RPM ( max is 3010 RPM ) and acceleration is set to 3000...

    Gear:

    • OK, i will test it without gearbox, but after test i need to make auto calibration again. Should this auto tuning setup be "compatible" with my M92 / M569 manual tuning defined in duet ?

    A.



  • Auto calibration is used to define how the servo works with the machine, fun to see the motor work. Other then remap outputs to the output board and calibrate steps per mm I didn’t make any other changes to Duet, other then miss wiring the motor it hard to damage the motor. Have you actually operated the motors with Duet?



  • I will test duet tomorrow. Can you share your M92 and M569 setup ?



  • My M92 and M569 are useless to your application which are machine specific and will be determined by the action of your machine. Mine is a corexy and I have not clue of what you are doing other then driving Clearpath servos with a Duet controller.



  • @Edkirk
    I agree. But is there anything else accept those two command , that i need to watch for ?

    And, do you define M569 for each drive (p5/6/7 ) ?

    A.

    A.



  • HI guys !
    We have finally set up the main rotary delta robot. Most of the problems ware in upper arm production and setup,but we solve it. Now it' time to wire all this. I will post picture of work in progress so someone alse can benefit from this too.

    Question:
    I need to run auto calibration on each motor but the upper arm is now tightened to gearbox shaft. As far as i remember in the first auto calibration test, motor shaft has turn full circle few times and i can not do this now... Should i just dismantle the upper arm and make calibration without it or is there a way to set some option in calibration setup routine ?
    A.


  • administrators

    I'm not sure what you mean by auto calibration, because RRF doesn't support that for rotary deltas. But you need to measure the upper arm angle at which each endstop triggers and put those angles into the M669 command.



  • i meant auto calibration as part of MSP software
    It's related just to clearpath motor setup.



  • Yes, you will need to add a T parameters to the M569 commands for the external drivers, which I presume are P5 P6 and P7. The Clearpath manual should say what values you need (they are step pulse width, step pulse interval, direction setup time, and direction hold time).


    I have completed MSP auto config on all motors and they are ready for duet test. I will try with one motor just to see if this will work.

    There is one thing that i dont understand...
    Dont i need to set M584 command to remap motors to x,y,z, for use on external driver ?


  • administrators

    Yes, M584 X5 Y6 Z7



  • I still can not make any motor movements.
    Just to be sure am doing this correctly, please guys, take a look at connections.... So far i have tested direct connection ( without 5V pin ) and with 5V pin. Pictures in attach...1_1564045713136_conne.JPG 0_1564045713136_wiresConn.JPG
    Btw. I have connected white, blue, black and green to 5V pin.



  • Sorry - your photos make no sense. I posted a photo of a working system back in January showing the Clearpath wiring plugged directly into the expansion board.



  • Hi EdKirk and thank you for reply.
    Really no need to apologize. I am in learning phase with this kind of setup so any reply is more then welcome.

    I have tried to connect wires on the exactly same way as you did ( from left to right --> orange/blue/brown/white/yellow/ black ) but there was no movement whatsoever, so i pulled all positive wires (inputA+, inputB+, enable+, HLFB+ ) and hook them to 5V pin. I was thinking that this would help solving the "logic" part because its written in manual that 5V is some startup voltage...

    Did you make some other HW changes ?
    Btw. this is the setup that am using at the moment and this are the command that i use for test :

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    ;------------------------------
    M569 P5 R0 T3:3:3:3
    M569 P6 R0 T3:3:3:3
    M569 P7 R0 T3:3:3:3
    M584 X5 Y6 Z7 E3:4

    Commands:
    G91
    G1 S2 Y50 F600

    Maybe there is a problem with my config setup ?
    0_1564063979239_picConnTek.png



  • If the wires are connected properly the motors will work when configured properly and given a proper command. You should be able to read VDC on the enable pins and if my memory is correct the motor will hold hard when enable is energized, can not turn by hand. I don’t know if there is a command to energize enable. I don’t think you will get voltage on step and direction because they are digital signals. You can use G Code to rotate motors but I don’t commit it to memory, you will have to look it up. dc42 has some routines posted, I last used it in his setup instructions when setting up my Delta printer. Also if frequency is set to high in Clearpath the rpm will be so slow it appears to not be moving, set at a low number. Check if motor is frozen when given a command with Duet that means you are getting enable signal and something is going on. For normal operation with Duet everything has to be properly set up and correct. I found it difficult to convert from other controllers to Duet, very steep learning curve. I couldn’t get Duet to work until I ran the configurator and followed the instructions, no short cuts.



  • I did it ! It's working.
    I have retested several times adapter that i hooked up to molex connector and everything was ok.
    Connections are soldered and solid.

    Finaly i decide to cut it and connect teknic wires directly to new inline connector.
    After sending G91 / G1 S2 X50 F1000 motor start to move slowly.

    The only thing i can think of is that the adapter wires ware to long and/or to big ( gauge)....

    Am working on this for lat 6 hours, and after i changed HW and config for X times i found that mistake is general one.. Damn, i really need start to drink 🙂 Thank you all for your comments !

    Maybe i will need help with fine tuning but this is another story...


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.