Cannot add network SSID to remembered list



  • Hi,
    As the title suggests, I've been stuck on the first step of using the duet 2 WiFi board. I'm using YAT and I've been trying to add my home network using the M587 S"your-network-ssid" P"your-network-password" (with my SSID and password replaced appropriately) command and I get a return that says the board failed to add the SSID to the remembered list. This was out of the box, I have since looked through the forum to find similar problems and this is what I've tried so far:
    -Updating the firmware (to the same version of 2.02) following Fallback Procedure #1 --- still fails to add SSID
    -Updating the firmware to the new 2.03 beta1 that came out yesterday --- still fails to add SSID

    I've now reverted to 2.02 and it still doesn't work so I ran the M122 command and here is the returned diagnostic:
    <
    <
    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DGM-917DA-G4MSJ-6J9D6-3S46J-1TPRB
    Used output buffers: 1 of 20 (1 max)
    === RTOS ===
    Static ram: 25524
    Dynamic ram: 98840 of which 0 recycled
    Exception stack ram used: 272
    Never used ram: 6436
    Tasks: NETWORK(ready,544) HEAT(blocked,1232) MAIN(running,3860) IDLE(ready,200)
    Owned mutexes:
    === Platform ===
    Last reset 00:02:21 ago, cause: software
    Last software reset time unknown, reason: User, spinning module GCodes, available RAM 6380 bytes (slot 0)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 26.8, current 29.0, max 29.1
    Supply voltage: min 0.0, current 0.3, max 0.3, under voltage events: 0, over voltage events: 0, power good: no
    Driver 0: ok, SG min/max not available
    Driver 1: ok, SG min/max not available
    Driver 2: ok, SG min/max not available
    Driver 3: ok, SG min/max not available
    Driver 4: ok, SG min/max not available
    Date/time: 1970-01-01 00:00:00
    Cache data hit count 311458241
    Slowest loop: 4.18ms; fastest: 0.06ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "M122" in state(s) 0
    aux is assembling a command in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 1329.94ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 0 of 8

    • WiFi -
      Network state is changing mode
      WiFi module is idle
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.22
      WiFi MAC address bc:dd:c2:89:9f:e0
      WiFi Vcc 3.40, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 31856
      Socket states: 0 0 0 0 0 0 0 0
      ok
      Error retrieving WiFi status message: SPI timeout
      WiFi module is idle
      Error retrieving WiFi status message: SPI timeout
      WiFi module is idle
      Failed to change WiFi mode (code -7)

    I now see there are some errors at the end there but need help on what to do now. Could it be a firmware issue or a board/WiFi module problem?

    Thanks in advance,

    Ed



  • Rather than sending the commands through YAT, you can try taking the SD card out of the duet, putting it in your PC and editing config.g to include you SSID adding command and then powering up the Duet. It it works you can then just remove the SSID command from config.g so it doesn't get run every time.



  • My Duet Wifi 1.04 would always forget about a third SSID network that I had set up, until I removed the test one that it ships with. I suspect that there isn't a lot of memory in the wifi module for networks. Remove any networks that are currently stored in there, and try again.


  • administrators

    1. Try re-installing the DuetWiFiServer firmware. Aside from the 1.22 version shipped with RRF 2.02, the 1.23beta1 version supplied with RRF 2.03beta1 is compatible 2.0, 2.01 and 2.02 versions of RRF

    2. Try sending M552 S0 before you run M587. If it still doesn't work, try M552 S-1 followed by M552 S0.



  • Thanks to everyone for replying so quickly, and big thanks to dc42!
    I installed the DuetWiFiServer firmware from the 2.03 beta1 as you suggested and then ran M552 S0 before M587 and it worked like a charm 🙂

    Got my IP now so time to set it all up!

    Thanks again to everyone, no more issues here.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.