Z Motors Move on X, Y Home - Brand New Cartisian Setup



  • So I just booted my wired Duet Wifi 2 with custom configuration & when I try to home X or Y it raises one or the other of the dual Z motors.

    I have a BLTouch wired sans the Duex expansion board as shown in the Wiki.

    Anyone have any thoughts? I've confirmed the correct motors are plugged into the right positions. I've also disabled Heater3 in the config file for the BLTouch.

    The wiring diagram for my stepper motors follow. I have them wired from left to right: Blue, Yellow, Red, Green

    stepper motor datasheet

    Duet wiring diagram


  • administrators

    The standard homing files generated by the online configurator for Cartesian printers raise Z by 5mm before homing X or Y. This is to avoid scraping the nozzle over the bed. If you have dual Z motors and your configuration is correct, it should raise both Z motors by the same amount.



  • Does the wiring on the stepper motors look correct?


  • administrators

    I have them wired from left to right: Blue, Yellow, Red, Green

    According to that extract from the stepper motor data that you posted, that is a suitable wiring order.



  • My config.g & homex.g files follow. I copied the values over from a Marlin 1.1.0 RC3 config file. Is the gcode syntax at least correct? Feel free to let me know if I'm asking too much. Also let me know if I should be providing more details.

    config.g:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Feb 14 2019 01:42:49 GMT-0600 (Central Standard Time)
    
    ; General preferences
    G90                                                ; Send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    
    ; Network
    M550 P"Pegasus 12"                                 ; Set machine name
    M552 S1                                            ; Enable network
    M587 S"REDACTED" P"REDACTED"       ; Configure access point. You can delete this line once connected
    M586 P0 S1                                         ; Enable HTTP
    M586 P1 S0                                         ; Disable FTP
    M586 P2 S0                                         ; Disable Telnet
    
    ; Drives
    M569 P0 S1                                         ; Drive 0 goes forwards
    M569 P1 S1                                         ; Drive 1 goes forwards
    M569 P2 S1                                         ; Drive 2 goes forwards
    M569 P3 S1                                         ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1                            ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E500.00                 ; Set steps per mm
    M566 X900.00 Y900.00 Z18.00 E120.00                ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z300.00 E1500.00          ; Set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z100.00 E10000.00           ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E800.00 I30           ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                   ; Set axis minima
    M208 X303 Y328 Z342 S0                             ; Set axis maxima
    
    ; Endstops
    M574 X1 Y1 S1                                      ; Set active high endstops
    
    ; Z-Probe
    M574 Z1 S2                                         ; Set endstops controlled by probe
    M307 H5 A-1 C-1 D-1                                ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000                              ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-33 Y0 Z2.5                              ; Set Z probe trigger value, offset and trigger height
    M557 X15:0 Y15:195 S20                             ; Define mesh grid
    
    ; Heaters
    M307 H0 B0 S1.00                                   ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700                        ; Set thermistor + ADC parameters for heater 0
    M143 H0 S150                                       ; Set temperature limit for heater 0 to 150C
    M305 P1 T100000 B4138 R4700                        ; Set thermistor + ADC parameters for heater 1
    M143 H1 S275                                       ; Set temperature limit for heater 1 to 275C
    
    ; Fans
    M106 P0 S0.3 I0 F500 H1 T45                        ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H-1                             ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    
    ; Tools
    M563 P0 S"Default Hotend" D0 H1                    ; Define tool 0
    G10 P0 X0 Y0 Z0                                    ; Set tool 0 axis offsets
    G10 P0 R0 S0                                       ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss
    
    ; Custom settings are not configured
    

    homex.g:

    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Feb 14 2019 01:42:50 GMT-0600 (Central Standard Time)
    G91               ; relative positioning
    G1 Z5 F6000 S2    ; lift Z relative to current position
    G1 S1 X-308 F1800 ; move quickly to X axis endstop and stop there (first pass)
    G1 X5 F6000       ; go back a few mm
    G1 S1 X-308 F360  ; move slowly to X axis endstop once more (second pass)
    G1 Z-5 F6000 S2   ; lower Z again
    G90               ; absolute positioning
    

  • administrators

    I'm not clear about what isn't working for you. I explained that the standard homing files raise Z by 5mm before homing X and Y. Is the problem that the Z motors are not turning by the same amount?

    Please test the motors individually, without homing them. First send G91 to put the motion in relative mode. Then send G1 S2 X20. This should move the X axis 20mm in the +X direction. Similarly, G1 S2 X-20 should move the X axis 20mm in the -X direction. Then test the Y and Z motors in the same way.



  • You wrote "one or the other", so it doesn't move both Z motors at the same time?
    The Z motors are connected to the ZA ZB connectors (Drive 2)?
    What is your supply voltage to the board?



  • I'm not clear about what isn't working for you. I explained that the standard homing files raise Z by 5mm before homing X and Y. Is the problem that the Z motors are not turning by the same amount?

    Yes, sorry for not making that more clear. ZA moves up with Y & ZB moves up with X. They do not move together. I will however attempt your suggestion & post results.

    The supply voltage to the board is 12V 30A.



  • Try to connect ZB to E1, assuming E1 is free. Then add proper maping in your config, right after M569 P3 S1 add:

    M569 P4 S1
    M584 X0 Y1 Z2:4 E3

    Also dont forget to put jumpers back on ZB connector.


  • administrators

    @ivxcvi said in Z Motors Move on X, Y Home - Brand New Cartisian Setup:

    Yes, sorry for not making that more clear. ZA moves up with Y & ZB moves up with X. They do not move together.

    1. Are you sure it is doing that consistently? It's very unusual.

    2. Are the Z motors definitely the same 1.5A type that you listed the data for? If you are converting another 3D printer to Duet electronics, they may be lower current motors and not suitable for a series connection.

    3. Your Z steps/mm is very high so you may need to reduce the Z acceleration, speed and jerk. I too have a printer with 4000 steps/mm on the Z axis and I use these settings:

    M201 X1200 Y1200 Z20 E1000 ; set accelerations
    M203 X15000 Y15000 Z250 E3600 ; set XYZ and extruder speeds
    M566 X1800 Y1800 Z30 E20 ; Maximum instantaneous speed changes mm/minute


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.