Laser Mode, Endstop Limit and Homing



  • Hello everybody,

    I've just finished to setup my cnc with the ethernet board + expansion board (external DM542T drivers).
    Everything is ok and now I try to add a laser head in addition of the spindle.
    0_1550657725885_IMG_0968.JPG

    All the wiring is ok and the laser is operational connected the ttl input (+ and -) of the laser module to the heater 6 pwm + gnd of the expansion board.
    Add the following line to the config.g to do the job :

    ; LASER Settings JEFF
    M307 H6 A-1 C-1 D-1       ; Disable Heater output on Heater 6
    M452 P6 R255 F200         ; Enable Laser mode, on output 6 (heater 6), with max intensity being 255, and a PWM frequency of 200
    

    I mean that entering Gcode M3 S255 trigger the laser and M5 stop it and G1 with S255 fire the laser and G0 no laser.

    I have change the homing sequence according to the evolution of Firmware 2.02 in laser mode (replace Sx parameter by Hx)
    For example for Z I have got :

    G91              ; relative positioning
    G1 H1 Z70 F1500 	; move quickly to Z axis endstop and stop there (first pass) - JEFF replace S1 by H1 (LASER MODE)
    G1 H2 Z-3 F2400      ; go back a few mm - JEFF add H2 to avoid error G0/G1 outside boundary
    G1 H1 Z70 F300 ; move slowly to X axis endstop once more (second pass) - JEFF replace S1 by H1 (LASER MODE)
    G90              ; absolute positioning
    

    The problem is that after this and homing, it's impossible to move the head.
    Each time I try to move (using DWC jog interface or by GCode command), I've got this error :
    Error: G0/G1: outside machine limits

    If I disable all the modifications for the laser mode, make homing and after in a macro put in laser mode, I can move.

    So, my questions :

    • Is there something I've done wrong ? Why the "outside machine limits" Error ?
    • If i want to use my cnc with a spindle and with a laser, I don't have to make it in a config.g but in a macro : 1 to enable laser mode and 1 to return in cnc mode ?
    • Is there something I don't undestrand in this laser mode feature ? What is the workflow / configuration to make it work with a spindle (double head configuration)

    config.g and homing file attached :
    homez.g
    homey.g
    homex.g
    homeall.g
    config.g

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet Ethernet 1.02 or later
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    Web Interface Version: 1.22.6

    Thank you for your answers


  • administrators

    Please can you identify which changes are causing it to fail. Is it when you change the S1 and S2 parameters in the G1 commands in the homing files to H1 and H2? Or is it when you add the M452 command to switch to laser mode?



  • Ok,
    I've just checked :

    Change homing files with H1 and H2 paramaters WITHOUT M452 Laser mode :
    Everything is OK (as before 🙂 ).

    Add the two lines to activate my laser head in config.g :

    ; LASER Settings JEFF
    M307 H6 A-1 C-1 D-1       ; Disable Heater output on Heater 6
    M452 P6 R255 F200         ; Enable Laser mode, on output 6 (heater 6), with max intensity being 255, and a PWM frequency of 200
    

    And then impossible to move after homing : ERROR : G0/G1 : outside machine limits

    Tell me if you have an idea


  • administrators

    It's a bug. In laser and CNC mode, any attempt to move outside limits is reported as an error unless limit checking has been disabled. But this should not apply to G1 H1 and G1 H2 moves. I will fix it in 2.03beta3. Meanwhile, I think you can work around the issue if you use M564 S0 at the start of your homing files to disable limit checking, and M564 S1 at the end to re-enable it.



  • Ok it's a bug but the workaround you explain is usefull only for the homing procedure. In this case, indeed I can homing safely with the M564 S0 / S1 statement.

    But after homing, I still have the error ERROR : G0/G1 : outside machine limits if I want to move with the jog interface in DWC. To do so, indeed I have to send the GCODE M564 S0 ; But you're agree with me that's not safe 🙂
    It's like the machine boundaries set up with these lines :

    ; Axis Limits
    M208 X0 Y0 Z0 S1                  ; Set axis minima
    M208 X857 Y1150 Z70 S0             ; Set axis maxima
    

    are not "compiled" / "understood" in the laser mode ?!?


  • administrators

    After homing, what are the XYZ coordinates displayed in DWC or on PanelDue?



  • I am using DWC and it displays X : 0, Y : 0, Z : 78,25
    I have a probe offset for the Z (I'va got to check)


  • administrators

    Please post your updated config.g and homing files, and I'll try to reproduced this tomorrow.



  • Here there are :
    config.g
    homeall.g
    homex.g
    homey.g
    homez.g

    thx



  • @jeffouille said in Laser Mode, Endstop Limit and Homing:

    I am using DWC and it displays X : 0, Y : 0, Z : 78,25
    I have a probe offset for the Z (I'va got to check)

    Your Z position after homing is beyond the configured max of 70

    M208 X857 Y1150 Z70 S0             ; Set axis maxima
    

    this at least explains the message.

    I have a probe offset for the Z (I'va got to check)

    This might be the reason why it is (thinking?) it is above Z max.



  • @wilriker said in Laser Mode, Endstop Limit and Homing:

    Your Z position after homing is beyond the configured max of 70

    That was it !!
    Thank you.

    Now without the tool offset. Everything is ok.
    I can move freely after homing


Log in to reply