DWC access IP



  • Hi,

    since 2 days i cant access to DWC in the established IP in config.g, i have:

    ; Network
    M550 PTLM Duet 2B ; Set machine name
    M587 S"TERRAZAExtender2.4GHZ" P"a1b2c3d4" I192.168.1.200
    M552 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet
    

    Now, the acces IP to DWC 192.168.1.113, i dont have config-override


  • administrators

    Remove the M587 command from config.g. it should not be in there. The command needs to be sent only once because the details are stored on the WiFi module.

    Send M587 without parameters to list the access points that the WiFi module knows about and the IP addresses it requests.



  • i have do some tests....

    how i can force, that Duet connects to one of the networks stored??

    If i send M587, by console, Duet respond with 4 wifi networks, and i d'like connect to one of them.... but it connects to another...

     M587
     Remembered networks:
     TNCAP2FCC19 IP=192.168.1.14 GW=0.0.0.0 NM=0.0.0.0
     DIR869l-2,4 IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0
     DIR869L-2,4 IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0
     TERRAZAExtender2.4GHZ IP=192.168.1.200 GW=0.0.0.
    

    I d'like to connect to the last.... i have do a macro:

     M552 S0 ;Desactiva el WiFI
     M587 S"TERRAZAExtender2.4GHZ" P"a1b2c3d4" I192.168.1.200 ;Establece el punto de conexion
     M552 S1 ;Activa el WiFi
     M587 ;Guarda los datos de conexion en el modulo Wifi
    

    but....

    M552
    WiFi module is connected to access point DIR869L-2,4, IP address 192.168.1.112
    

    Duet connects to another router.....



  • The P parameter of M552 can tell it what network to use from the list previously stored onto the wifi using M587.

    Use M588 to delete networks.

    I've not got a wifi to test this on, just searched the gcode guide: https://duet3d.dozuki.com/Wiki/Gcode


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.