RepRap firmware tuning



  • I’m currently running Reprap firmware on one small Cartesian printer, but experience some issues. I use Cura slicer and had to decrease the filament flow to 85 % and still there are some issues at the layer finishing corner, attached some pictures. The pressure advance option is not activated and the following are the motor configs:

    M92 X800 Y800 Z8000 E200 ; Set steps per mm
    M566 X900 Y900 Z60 E800 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z200 E800 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z100 E150 ; Set accelerations (mm/s^2)

    0_1551275531716_pic1.jpg
    0_1551275541256_pic2.jpg


  • administrators

    It could be a temperature issue. There was a bug fixed in the online config tool recently, that could mean you are using the wrong thermistor parameters. What hot end thermistor are you using, and what parameters are in your M305 H1 command in config.g?



  • @mitko said in RepRap firmware tuning:

    E200

    have you calibrated your extruder manually?
    i.e extruding 100mm and checking that the length is 100 mm



  • 200 steps per mm is an odd number for the extruder. Is it direct drive?

    Confirm your thermistor values are correct
    Run PID tuning on the heater
    calibrate the extruder steps per mm
    Then fine tune the slicer flow setting
    Then start to introduce some pressure advance



  • Thanks about your suggestions and recommendations, I was able to obtain better results by using the following motor configurations:

    M92 X800 Y800 Z8000 E188.68 ; Set steps per mm
    M566 X1000 Y1000 Z60 E1000 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z180 E1200 ; Set maximum speeds (mm/min)

    as well as decreasing the printing speed to 17 mm/s.
    However still some noticeable spot remain at the corner. 1 – was printed at 248º C 2 – 235º C.
    0_1551457320528_pic5.jpg

    The issue seems that this is a finishing corner and the movement returns via the same path:
    0_1551457337546_pic4.jpg

    Not sure if I should look at other RepRap adjustments, look for other slicer ? Attached the g-code file: 0_1551457416073_test3.gcode


  • administrators

    Did you check the M305 thermistor parameters?



  • @dc42, My M305 config:

    M305 P0 T22000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1

    I use direct drive MK8 extruder with 0.4 mm diameter nozzel:
    0_1551462206862_extruder.jpg

    With other firmwares, I had β=3950, but I tried a range of extruder temperatures, ±15º C it doesn’t seems to make much difference.

    The other temperature factor is that I am printing in a garage @ about 10º C .

    The filament is some inexpensive ABS, the quality is not so good and I have to use higher extruding temperature for better layer bonding.



  • where did you get those values from?

    i would certainly try pla first and calibrate your printer with that before trying abs



  • im fighiting this from i buy the maestro, i resolv almost all problem but i cant i just cant get rid of this retraction un retraction problem, if i print from sd card the inboard software its worst, i did the repetier emulator setting in the config, and print from repetier directly but still have this

    i buy this board to get the last hair from perfect print and its a lot worst yesterday i reinstall my old mks gen1.1 and all get back where it was, a 20$ board prit better than this one .

    i didint let go the maestro i want to get this to work but... no sleep night start to get me hahahah

    you need to get extruder speed to the fastest you can first:

    M566 X1000.00 Y1000.00 Z300.00 E5000.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z1000 E10000 ; Set maximum speeds (mm/min)
    M201 X3500 Y3500 Z300 E7200 ; Set accelerations (mm/s^2)

    try this and report



  • I tried different settings, bellow are the results:

    0_1551633844894_pic1a.jpg

    1- 245º C
    2- 235º C

    0_1551633863764_pic2a.jpg

    3- 245º C , settings recommended by secretman, retraction distance 4 mm, E188.48 steps per mm
    4- 245º C , settings recommended by secretman, retraction distance 5 mm, E188.48 steps per mm

    @secretman, your settings did some improvement in case 3 and 4. It seems kind of strange that increasing the retraction distance actually makes the undesirable artifacts larger.



  • @mitko said in RepRap firmware tuning:

    .48

    no the point was the speed u need to keep your step/mm setting
    retraction 5 mm is a bowden setup i wanted you to just speed up de retraction and acceleration haha ur printing abs did you have the cooling fan on for your print?



  • @mitko
    do you calibrate your extruder step /mm ? 10mm extrude 10 mm?
    your square is square dimention are good?
    cube 20x20x20 is realy 20x20x20?



  • @secretman , By changing the step/mm setting the intention was to see if it going to change something. In general the printer is calibrated. Well there are some deviations, for example instead of 10.00 mm got 10.06 mm for Y-axis, but this is related to the printer mechanics. The printer is a modified version of Graber i3, and there is some angle between the Y-motor and the belt bed holder, this seems to provide error.
    But your speed settings are too fast for this printer, had problems today with the Z-axis.
    Still I do not think that the issue is only associated with the retraction. I do not have cooling fan on the nozzel, because this material tends to deform very easily even from the extruder cooling fan.



  • @mitko
    completly in accord with you its the retraction speed the problem, not only that but.... i dont understand why duet need to retract and undo with out moving.... stop retrac move undo retract then go... that why you need fasters speed ans accelaration and jerk for the extruder....

    your dimention are ok then and



  • @secretman, not so clear. In general the G-code is linear, it is executed line by line. For example, I’m very displeased that I have to wait first my heated bed to reach the heating temperature, later the extruder. It is unclear to me how the G-code is executed in RepRap, if there is any look ahead or out of order execution optimization. To the best of my understanding currently only @dc42 can address those issues.

    I tried today tuning the heaters, the extruder tuning went fine, but for the bed heater got:

    2:27:07 PMWarning: Auto tune of heater 0 failed due to bad curve fit (A=71.2, C=303.0, D=-8.9)
    2:22:27 PMAuto tune phase 3, peak temperature was 105.1
    2:22:20 PMAuto tune phase 2, heater off
    2:11:00 PMAuto tune phase 1, heater on
    2:10:54 PMM303 H0 S105
    Auto tuning heater 0 using target temperature 105.0°C and PWM 1.00 - do not leave printer unattended
    2:08:27 PMWarning: Auto tune of heater 0 failed due to bad curve fit (A=112.3, C=532.3, D=-1.8)
    2:00:19 PMAuto tune phase 3, peak temperature was 105.0
    2:00:13 PMAuto tune phase 2, heater off
    1:45:17 PMAuto tune phase 1, heater on
    1:45:11 PMM303 H0 S105
    Auto tuning heater 0 using target temperature 105.0°C and PWM 1.00 - do not leave printer unattended



  • i understand the part line by line but you can do a g01 in z and a e -5 in the same line, and you just get me to the point i will try this change all retraction same time as the move..... i dont know how repetier firmware work flawless and marlin too on my old crap ramp 1.4 board , and on the best one i just get farrr away of what i was still fighting the blob the retraction seam, patio slicer get better face quality but retraction problem is the same....

    @dc42 i got a question did is better to enable the firmware retraction in the slicer ? if i print from sd i got worst peice, if i print from repetier i got better result but the retraction is not firmware enable

    for the heater this part is easy:
    For example, I’m very displeased that I have to wait first my heated bed to reach the heating temperature, later the extruder.

    you need to cvhange in your software(slicer ) one command
    M190: Wait for bed temperature to reach target temp
    to M140: Set Bed Temperature (Fast)

    easy enought but will start right away when the hotend get to temp



  • for your auto tune you need to add the setting to your config file for it to load
    and if the bed is not pid you cant get it so work too...


Log in to reply