Fan questions and odd behavior



  • 0_1551376450099_config.g

    Config attached.
    Printer: Ultimaker Original Plus *Note cause Ultimaker is an odd ball in the motion systems I set this up as Cartesian and reversed a few of the axis.
    Board: Duet 2 Maestro v1.0 /with PT100 daughter board v1.1
    Firmware: 2.02RC5(RTOS)
    Web Int: 1.22.5

    Question with issue #1. My hotend fan. Current problem. Its running all the time no matter the temp.

    My goal with the hotend fan is common. I wish to have this fan activate to 100% when temperature on the hotend exceeds 45c. The fan is a Noctua NF-A4x10 FLX 3 pin. It is plugged in to fan port 2 using the following config code.

    M106 P2 S0 I0 F500 H1 T45

    If I understand correctly this states via M106 command that on fan port 2 it will run at 100% at a frequency of 500htz when thermal temp on H1 is above 45c. The probes are PT100 off the PT100 daughter board. They are addressed correctly in the config so I assumed H1 would work no matter what as long as its defend and address properly in M305 and M143.

    Question with issue #2. The fan will not start spinning unless I flick it or move the blades my self to get it started. Once started it will run. This printer runs on 24v so the fan outputs are 24v or 5v depending on what the jumper is set to. Unless there is another way around that on the board i'm left with only a few options. Get a 24v fan, get a 5v fan or step down the voltage for a 12v fan. Since I hade a few Polulu 12v 600a step down regulators on hand I used one for the output of fan port 2. Not sure if this has anything to do with my problem but I thought it worth mentioning.

    That's about it for now. This is my first 32bit board and im beyond impressed with its capabilities and performance.

    Thanks for you help.



  • It's recommended to use Fan1 for the hotend since it will turn on automatically at startup briefly incase the printer power cycled while the hotend was hot. The default fan definition is setup to automatically start at 45c. M106 P1 T45 H1

    https://duet3d.dozuki.com/Wiki/Connecting_and_configuring_fans

    For the Noctua fan you may need to increase the PWM frequency from F500 to a value substantially higher to get good speed control over a wide RPM range. Try F25000. You may also need to add a short blip value which uses 100% power at first to overcome initial resistance to rotation. B0.5 should be plenty.

    You can provide 12v to the fan ports by connecting a 12v supply to the VFAN pin. This is usually done through a buck converter.

    All that and more described in the link above.



  • Confirmed. Both problems have been resolved.

    Moved the hotend fan to fan jumper 1, removing S0 ,and changing frequency to 25000 then adding blip interval B0.5
    Resulting in " M106 P1 F25000 B0.5 T45 H1 "

    All working as desired. Thanks for the assists Phaedrux !



  • Glad you got it sorted.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.