Faulty z-probe on Smart effector



  • Hello,
    I'm new to Duet3D, I purchased a duet2wifi in begin of february to replace my previous board (Lerdge x) on my delta.
    I begin to get used with the configuration, little more difficult than with the Lerdge firmware but so much more possibility of settings. I just started playing with pressure advance, so great feature.
    I also bought a smart effector with 713maker adapter for rostock ballcup.
    0_1551378696559_Delta.jpg

    But I have problem with z-probe.
    It continuously trigger even with the board alone (without heatsink, arms...), green trigger light and 1000 value in web control.
    I check documentation and all wire, everything seems ok (tested with voltmeter).
    For the moment i use my old nozzle zprob from lerdge.
    0_1551378791706_Effector.jpg

    I make a request to the seller (e3d) which ask me to post on the forum.
    I was careful to use nylon washer under each screw and assemble each element correctly.
    After inspection of the smart effector board, I suspect a tiny defect on the strain gauge near the brand logo:
    0_1551378856100_Smarteffector.jpg

    Do you see other possibilities or tests to be done?


  • administrators

    @memeng said in Faulty z-probe on Smart effector:

    It continuously trigger even with the board alone (without heatsink, arms...), green trigger light and 1000 value in web control.

    Does it trigger continuously when no fans are running? The varying magnetic fields from fans can cause triggering.

    If the strain gauge traces get damaged, the usual result is that the probe fails to trigger. But that's not the only possibility. If you use magnification, can you tell whether that blemish has cut or damaged a trace?



  • @dc42 said in Faulty z-probe on Smart effector:

    magnification

    I does all my fisrt testing without fans and it was already triggering.
    Then I tried the card alone with only the z-probe connected, with the same result.

    I will watch and try to send a magnified photo


  • administrators

    If you have a multimeter, please see this post https://forum.duet3d.com/post/25242 (the one from me dated 1 September) to see how to measure the resistances of the strain gauge traces.



  • So it's not easy to see even with a 30x magnifying glass.
    I can see the filaments but I do not know if they are cut or if there is a contact.
    Below, it's a little blurry but it's representative of what I can see :
    0_1551453443123_IMG_20190301_135054.jpg

    I will make some resistance measurements tonight.



  • So I took some resistance measures.
    I did not dismount everything, just unplugged the 8-way connector.
    Between r11 and r13 I have 0.03 Ohm and r11 and r14 I have 16.60 Ohm...


  • administrators

    I think you have probably measured using the wrong end of one of the resistors. There are better instructions for measuring the resistance at https://forum.duet3d.com/topic/9038/smart-effector-z-probe-no-longer-working/7.



  • Yes, I saw this thread too before make measures.
    I took the measurements as shown between R11 right and R13 R14 left several times.
    I can try again.


  • administrators

    A short across one of the traces would certainly explain why the probe isn't working. But I can't envisage how such a short would occur.



  • Indeed, I made a mistake on the units on my mulimeter, but I still have this important differences between the two resistors.
    I have for r11 - r13 : 35 ohm
    And for r11 - r14 : 16.6 kohm


  • administrators

    Looks like the R11-R14 trace is broken. If your Smart Effector is under warranty and you didn't cause the damage yourself, ask for a replacement.



  • Ok, I will contact seller.
    For information, r11-r14 corresponds to what trace, upper or under side ?


  • administrators

    R11-R14 is the upper side.


Log in to reply