Duet 3D Static IP not working



  • Can someone tell me how to set a static IP for my Duet 3D. I have seen similar threads from other users with the same problem but nothing seems to work for me.

    I have tried loads of different methods I have read online but whatever I do, the IP address stays at 192.168.1.28 which is set by DHCP

    This is the relevant bit of my config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Fri Mar 01 2019 11:38:38 GMT+0000 (GMT)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"My CNC" ; Set machine name
    M552 S1 ; Enable network
    M587 S"" P"****" I192.168.1.9 J192.168.1.1 K255.255.255.0 ; Configure access point and IP addresses. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    As far as I understand, this should set the IP to be 192.168.1.9 but it doesn't work

    Can someone help please?

    Peter


  • administrators

    M587 wasn't intended to be used within config.g. Please try sending it from DWC instead, or alternatively from a macro file. Make sure that you include the SSID of the access point in the quotation marks after the S parameter (your example shows the SSID as empty).

    Then run M587 without parameters. It should list the known SSIDs, with the IP address you specified (or 0.0.0.0 if you didn't specify one).

    If the readback looks correct, reboot the Duet and see whether the IP address has changed.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.