Unable to ''connect'' to duet server after re-installing FW



  • Hi,
    I am unable to connect to duet server. I erased my SD card, reinstalled latest firmware and duet server. However, I am unable to ''connect'' to wifi server. Whenever I click ''connect'' on the IP, nothing happens.

    This is my log from YAT

    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DGM-956GU-DJMSJ-6J9DL-3SN6R-TTQ3F
    Used output buffers: 1 of 20 (10 max)
    === RTOS ===
    Static ram: 25524
    Dynamic ram: 98124 of which 0 recycled
    Exception stack ram used: 312
    Never used ram: 7112
    Tasks: NETWORK(ready,836) HEAT(blocked,1232) MAIN(running,3776) IDLE(ready,200)
    Owned mutexes:
    === Platform ===
    Last reset 00:06:55 ago, cause: reset button or watchdog
    Last software reset at 2019-03-01 18:11, reason: User, spinning module GCodes, available RAM 6664 bytes (slot 2)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 40.5, current 42.5, max 43.4
    Supply voltage: min 24.3, current 24.4, max 24.7, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 1970-01-01 00:00:00
    Cache data hit count 1357433627
    Slowest loop: 100.08ms; fastest: 0.08ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 0 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "m122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 23.05ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 0 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.22
      WiFi MAC address 5c:cf:7f:76:6e:c8
      WiFi Vcc 3.39, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 29640
      WiFi IP address 192.168.1.7
      WiFi signal strength -72dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0
      ok


  • @cozyp said in Unable to ''connect'' to duet server after re-installing FW:

    WiFi signal strength -72dBm

    Your wifi connection is very weak.

    See here for some tips on improving it: https://duet3d.dozuki.com/Wiki/WiFi_disconnections_and_AJAX_timeout_errors



  • the thing is, that it was working before. Can't do anything about the weak signal, I am already using a signal extender....
    Check the images of the web interface, seems weird...1_1551543988955_duet 2.PNG 0_1551543988953_duet 1.PNG





  • @phaedrux I erased the firmware and tried to re-install the beta one, but bumped in the most common error.

    combined2firmware.bin not found......
    Let me solve that annoying error first and will re-try



  • @Phaedrux yes, it worked...... CASE CLOSED


Log in to reply