Duet wifi controlled dbot corexy based

  • administrators

    Check that your homez.g file and the Z homing section of homeall.g is set up to use a microswitch, not a Z probe. See https://duet3d.com/wiki/Configuring_RepRapFirmware_for_a_Cartesian_printer#Homing_files

  • hello thanks for the advice works well now … how do I know the values to be set for acceleration, velocity and jerk? thank you so much

  • Sorry for the trivial question… but I'm trying to learn

  • administrators

    It depends a lot on your printer mechanics.

    Acceleration: values of 1000 to 3000 are typical for X and Y. Start with 1000, then later you can try increasing it. Too much acceleration and you will lose steps on travel moves and/or see ringing artefacts in the print. For the Z axis of a Cartesian printer, use a much lower value, for example 50.

    Jerk: too much jerk will cause jarring sounds, ringing or missed steps. Too little and curves will print in a jerky manner. Try 1200 for X and Y jerk. The Z jerk value should again be much lower on a Cartesian printer, perhaps 30.

  • hi, thanks I will test all the values that you told me. I bought a npn sensor for auto-leveling and reading the wiki is written using a diode .. what type of diode does it take? thank you

    NPN output normally-open inductive or capacitive sensor
    Connect its output wire to the cathode of a diode, and the anode of the diode to the E0 STP pin. Connect the sensor ground wire to a ground pin on the Duet, and the sensor's + power wire to a suitable voltage (typically to VIN because these sensors usually need between 6 and 30V power).
    The diode should preferably be a small-signal Schottky diode such as BAT43 or BAT85, but a small signal silicon diode such as 1N4148 works for some people.
    Select mode 4 in the M558 command. If using firmware 1.15e or earlier, include M574 E0 S0 in config.g to select active low logic level for the Z probe. If using firmware 1.16 or later, include parameter I1 in the M558 command instead.

  • administrators

    As stated in the text you quoted, a small signal Schottky diode is recommended. Some users found that a 1N4148 or similar didn't work.

  • Why not a voltage divider? I used this on my npn for now since I didn't have a scotcy diode lying around. Are you worried about the effect needed by the sensor?

  • administrators

    You don't need a voltage divider because an npn output sensor connects the output to ground. The purpose of the diode is to protect the Duet in case the ground wire to the NPN sensor gets disconnected, which would typically result in the sensor putting nearly +12V or +24V on its output pin.

  • I connected npn but the LED on the sensor is always on … in the videos I've seen on youtube, the LED should light up only when you approach the plan?

  • I entered the command M558 P4 X0 Y0 Z1 I1 in the config file but the LED is always on … when I give the g30 s-1 command me error "Z probe Already triggered at the start of probing move" something wrong ?? thank you so much
    p.s. i'm used the but85 diode for the signal probe...

  • administrators

    If the LED on the sensor is always on, there is something wrong with the sensor. Does it have a sensitivity adjustment?

  • I tried to change the sensitivity but always remains a link light. The positive I take it directly by a 24v is wrong? the negative and the signal on the pins instead dell'e0 stop … could be the sensor ?? thank you

  • is the broken sensor or I do something wrong?

  • administrators

    I suggest you try connecting the sensor to just +24V and ground, directly to the power supply terminals or to an always-on fan output (make sure you get the polarity right). Leave the output wire unconnected. If the sensor light is still always on now matter how the sensitivity adjustment is set, then the sensor must be faulty.

  • I managed to run the npn sensor … the problem is that after the homing the duet has disconnected from the Internet and now you do not connect via usb even more I unplugged all the outlets but not goes ... what could this happen ?? It worked great before

  • administrators

  • Thank you very much… now it works maybe I accidentally pressed erase ... to make the sensor was enough to put the aluminium plan to grounded ... which means?

  • hi I just plugged the PT100 sensor but when I go to extrude me error:
    Error: Temperature reading fault on heater 1: sensor hardware error

    How can I fix the problem? thanks

  • Have you edit your config.g to set it to use PT100?

  • yes…

    ; Thermistors and heaters
    ;*** You can use S and B parameters to define the parameters of the thermistors you are using
    M305 P0 R4700 H0 L0					; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 X200  ;R4700 H0 L0					; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
    M305 P2 R4700 H0 L0					; Put your own H and/or L values here to set the second nozzle thermistor ADC correction

Log in to reply