Duet wifi controlled dbot corexy based


  • administrators

    You don't need a voltage divider because an npn output sensor connects the output to ground. The purpose of the diode is to protect the Duet in case the ground wire to the NPN sensor gets disconnected, which would typically result in the sensor putting nearly +12V or +24V on its output pin.



  • I connected npn but the LED on the sensor is always on … in the videos I've seen on youtube, the LED should light up only when you approach the plan?



  • I entered the command M558 P4 X0 Y0 Z1 I1 in the config file but the LED is always on … when I give the g30 s-1 command me error "Z probe Already triggered at the start of probing move" something wrong ?? thank you so much
    p.s. i'm used the but85 diode for the signal probe...


  • administrators

    If the LED on the sensor is always on, there is something wrong with the sensor. Does it have a sensitivity adjustment?



  • I tried to change the sensitivity but always remains a link light. The positive I take it directly by a 24v is wrong? the negative and the signal on the pins instead dell'e0 stop … could be the sensor ?? thank you



  • is the broken sensor or I do something wrong?


  • administrators

    I suggest you try connecting the sensor to just +24V and ground, directly to the power supply terminals or to an always-on fan output (make sure you get the polarity right). Leave the output wire unconnected. If the sensor light is still always on now matter how the sensitivity adjustment is set, then the sensor must be faulty.



  • I managed to run the npn sensor … the problem is that after the homing the duet has disconnected from the Internet and now you do not connect via usb even more I unplugged all the outlets but not goes ... what could this happen ?? It worked great before


  • administrators



  • Thank you very much… now it works maybe I accidentally pressed erase ... to make the sensor was enough to put the aluminium plan to grounded ... which means?



  • hi I just plugged the PT100 sensor but when I go to extrude me error:
    Error: Temperature reading fault on heater 1: sensor hardware error

    How can I fix the problem? thanks



  • Have you edit your config.g to set it to use PT100?
    https://duet3d.com/wiki/Connecting_PT100_temperature_sensors



  • yes…

    ; Thermistors and heaters
    ;*** You can use S and B parameters to define the parameters of the thermistors you are using
    M305 P0 R4700 H0 L0					; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 X200  ;R4700 H0 L0					; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
    M305 P2 R4700 H0 L0					; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
    
    


  • does anyone have any idea what could be?


  • administrators

    Are you certain that you have connected your PT100 to the first input channel and not the second? Try X201 in your M305 command instead of X200.

    Also if you have a ribbon cable from a PanelDue plugged into the SD_CONN connector, try disconnecting it.



  • I solved it by placing more double wires, now works fine. I only have a problem when I hand printing the extruder is too far from the plate.

    [[language]]
    ; homeall file for use with dc42 Duet firmware on CoreXY printers
    ; This file assumes the endstop switches are at the low end of each axis.
    ; Reverse the X and Y movement for high-end switches.
    ; Adjust the bed upper and lower limits in config.g (M208 commands) to get the correct homing positions
    
    G91                       ; relative mode
    G1 S1 Z10
    G1 S1 X-640 Y-430 F3000   ; course home X or Y
    G1 S1 X-640               ; course home X
    G1 S1 Y-430               ; course home Y
    G1 X4 Y4 F600             ; move away from the endstops
    G1 S1 X-10                ; fine home X
    G1 S1 Y-10                ; fine home Y
    
    M558 P4 X0 Y0 Z1 I1 
    G1 S1 Z-640 F500
    G1 S1 Z-10
    
    ; If you are using a microswitch for Z homing, insert similar code for the Z axis here,
    ; but use lower feed rates suitable for your Z axis.
    
    G90                       ; back to absolute mode
    
    ; If you homed the Z axis using an endstop switch, you can insert a G92 command here to correct the height.
    
    ; The following code assumes you are using a Z probe to do Z homing. Remove it if you are using a microswitch.
    ; Adjust the XY coordinates in the following to place the Z probe over a suitable spot,
    ; preferably near the centre of the bed if your Z probe supports that
    
    G1 X260 Y150 F2000
    G30
    
    ; This file leaves the head at the zprobe trigger height so that you can slip a piece of paper under it and then do G0 Z0 to check the height.
    ; If you prefer to send the printer to X0Y0Z0, un-comment the following lines
    G0 X0 Y0 Z0 
    ;G91
    ;G0 Z0
    
    

    after running the g30 it goes down and stays away from the extruder and when printing the non-return to zero … how do I fix?



  • hi, I have a problem with g32 after running it I will lower the level of 5mm and of the press away from the nozzle … how can I fix this? I not really understand where I'm wrong


  • administrators

    Sounds like you haven't set your Z probe trigger height. It's the Z parameter in the G31 command in config.g.



  • It has been set that value
    [c] G31 Z-0.02 P50
    [/c]

    p50 for a npn probe is correct? When I probe with G30 S-1 it works well … with G32 instead of the dish does not rise up to the nozzle ... as I installed firmware 1.18 beta 1 could be the problem?


  • administrators

    If you have an inductive probe then Z-0.02 in your G31 command is definitely not correct. You need to put in whatever height the probe triggers at in the Z parameter. The P parameter is much less important, but P100 or lower gives you the fastest response and on debouncing.


Log in to reply